DirecTV Subtitles not extracted

I have tried creating recordings with both “Closed Captioning” and “DirecTV Subtitles” settings from within the DirecTV.

MCEBuddy is set to:
“Extract subtitles and closed captions” = enabled

I have tried with “Add subtitles and chapters” enabled and disabled

Yet the subtitles are still embedded and never extracted to separate files.

Attach your conversion log. Is the log showing that the subtitles were extracted ?

Closed Captioning subs:
HDPVR2_20170713_0659.m2ts-Convert to MKV-2017-07-13T07-47-38.4145236-07-00.log (640.9 KB)

DirecTV Subtitles:
HDPVR2_20170713_0659.m2ts-Convert to MKV-2017-07-13T07-55-05.2177515-07-00.log (616.9 KB)

mcebuddy.conf (7.0 KB)

According to the logs ccextractor didn’t find any closed captions in the stream. If you can upload the original DirecTV video file to type MCEBuddy upload server we can analyze it.

I’m no stranger to FTP and I have followed the instructions found at this link for uploading using IE, FF, Windows Explorer and Filezilla, but nothing works.

Here’s what happens with latest version of Filezilla

Error: Could not connect to server
Status: Waiting to retry…
Status: Resolving address of
Status: Connecting to…
Status: Connection established, waiting for welcome message…
Response: 220 Welcome to the MCEBuddy server. If you are not a member of the Early Access program you can join at MCEBuddy - Home
Command: AUTH TLS
Response: 234 AUTH command ok. Expecting TLS Negotiation.
Status: Initializing TLS…
Error: GnuTLS error -48: Key usage violation in certificate has been detected.
Error: Could not connect to server

Therefore, I’ve uploaded to my own server for your review.

1 Like

Thanks, yes dug deeper into this. The latest version of FileZilla has broken secure certificates. We will upload a working version of FileZilla in the ReadMe post that you can use or you can use another client like Windows FTP or WinSCP.

EDIT: Fixed the issue, disabled TLS on the upload server. Filezilla’s latest version has a problem with self signed TLS certificates.

I was able to upload using Windows File Explorer. Tried yesterday by copying and pasting name and password but no luck. Tried again today this time typing the password and it worked.

Here’s the file name:

EDIT: I confirmed Filezilla now works as well.

1 Like

Your input file doesn’t contain any closed captions/subtitles, only audio and video:

Input #0, mpegts, from ‘HDPVR2_20170713_0659.m2ts’:
Duration: 00:00:31.40, start: 151.187722, bitrate: 14678 kb/s
Program 1
Stream #0:0[0x1011]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 29.97 fps, 59.94 tbr, 90k tbn,
59.94 tbc
Stream #0:1[0x1100]: Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, 5.1(side), fltp, 384 kb/s

If it has subtitles there will show up as a separate stream like:

Input #0, mpegts, from ‘The Bridges That Built London_20120614_DVB.ts’:
Duration: 00:01:38.20, start: 0.151678, bitrate: 4308 kb/s
Program 1
Stream #0:0[0x30]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 15000 kb/s, 25 fps, 25 tbr, 9
0k tbn, 50 tbc
Stream #0:10x40: Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 256 kb/s
Stream #0:20x50: Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006)

That’s why there’s nothing extracted.

Thank you for taking the time to look into this.

Yes, as I pointed out in the text file within the zip file I knew there wasn’t a sub title stream in the files. However, there are subtitles showing when the media plays.

HDPVR2_20170713_0658 show up at top in yellow with transparent background
HDPVR2_20170713_0659 show up on bottom white on black

Are you saying there is no way to extract them?

If they can’t be extracted, then everyone must be having the same problem with DirecTV recordings?

It could be the subtitles are outside the media file and stored/streamed separately. I also checked with MediaInfo tool which checks for embedded streams and didn’t find anything inside the file. You can try that yourself, much more intuitive than ffmpeg.