Constant Frame Rate


#1

Sorry but I’ve been struggling with the commands in the MP4 Normal profile to get handbrake to write the file with a constant frame rate instead of variable. I’ve tried using the -q command, but I guess I’m putting it in the wrong place. Can someone point me in the right direction on how to get it to create the MP4 files with a constant frame rate of 30fps? The profile I’m trying to edit is below.

[MP4 Normal]
Description=Main profile, good quality 1 pass MP4 (H.264/AAC) conversion. Good for most conversions, produces good results and is faster than the two pass conversion.
order=handbrake,ffmpeg,mencoder
mencoder-general=-ss 3 -vf pullup,softskip,yadif=0:-1,hqdn3d,harddup
mencoder-video=-ovc x264 -x264encopts bitrate=1400:me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=3:rc_lookahead=50:keyint=25:keyint_min=20:bframes=1:weight_b:level_idc=40:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=0:threads=auto
mencoder-audio=-oac faac -faacopts br=160:mpeg=4:tns:object=2
mencoder-audioac3=-oac faac -faacopts br=256:mpeg=4:tns:object=2
mencoder-ext=.avi
mencoder-remuxto=.mp4
mencoder-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1400k -x264opts me=hex:trellis=1:subq=8:partitions=all:8x8dct=1:ref=3:rc-lookahead=50:keyint=25:min-keyint=20:bframes=1:weightb=1:level=4.0:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=0:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
ffmpeg-audioac3=-acodec libfdk_aac -ab 256k -cutoff 18000 -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2 -f mp4 -O
handbrake-video=–start-at duration:3 -e x264 -b 1400 -x me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=3:rc-lookahead=50:keyint=25:keyint-min=20:bframes=1:weight-b:level-idc=40:b-pyramid=normal:direct-pred=auto:mixed-refs:deblock=-1,-1:nofast-pskip:nodct-decimate:b-adapt=0:threads=auto
handbrake-audio=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 256 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

Thanks.


(Goose) #2

First, files are constant frame rate, I haven’t seen any “variable” frame rate files. The frame rate depends on the source file, you can however change it without having to mess with the profile, in the Conversion Task -> Expert Settings page you can enable the option to change the frame rate and set it to what you want.

Do you mean a constant bitrate? MP4 Normal is a constant bitrate profile. The -q parameter in handbrake indicates you want a variable bitrate.


#3

I know this is an old post but this thread has reference to an issue I have been trying to resolve. Under Conversion Task->Advanced Setting (I dont see an “Expert Settings”) I cannot find an option to change the frame rate. Is it a setting that isn;t obvious? I see Maximum Width, Quality, etc. but no “frame rate”. I am using 2.3.13. Is this setting in a newer version? Thanks.


(RBoy) #4

Yes, the premium version has 500+ new features, enhancements and bug :bug: fixes