Can't get "MP4 Normal" to use Handbrake

I’m a new user, and I’m seeing that all of my conversions with the “MP4 Normal” profile seem to end up using ffmpeg. I see Handbrake failing in the log file, but I’m not sure I understand the cause. Here’s the pertinent section of the log file:

INFORMATION> 2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Handbrake checking for OpenCL and QuickSync support
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Launching process C:\Program Files\MCEBuddy2x\handbrake\handbrakecli.exe
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Process arguments -i null -o null
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> UI Session Admin Process : True
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Starting process as a UISession process with Admin privileges. This requires atleast 1 user to be logged into the system (remote desktop or locally)
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Setting process priority to Normal
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] hb_init: starting libhb thread
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] thread 6706e80 started (“libhb”)
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> HandBrake 20170728192513-45a24df-master (2017080101) - MinGW x86_64 - https://handbrake.fr
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> 8 CPUs detected
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> Opening null…
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] CPU: Intel® Core™ i7-4790 CPU @ 3.60GHz
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] - Intel microarchitecture Haswell
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] - logical processor count: 8
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] Intel Quick Sync Video support: no
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] hb_scan: path=null, title_index=1
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> src/libbluray/disc/disc.c:274: failed opening UDF image null
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] bd: not a bd - trying as a stream/file instead
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> libdvdnav: Using dvdnav version 5.0.3
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> libdvdread: Encrypted DVD support unavailable.
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> libdvdread: Can’t stat null
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> No such file or directory
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> libdvdread: Could not open null
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> libdvdnav: vm: failed to open/read the DVD
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] dvd: not a dvd - trying as a stream/file instead
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] hb_stream_open: open null failed
2017-11-09T22:43:30 MCEBuddy.AppWrapper.Handbrake --> [22:43:30] scan: unrecognized file type
2017-11-09T22:43:31 MCEBuddy.AppWrapper.Handbrake --> [22:43:31] libhb: scan thread found 0 valid title(s)
2017-11-09T22:43:32 MCEBuddy.AppWrapper.Handbrake --> No title found.
2017-11-09T22:43:33 MCEBuddy.AppWrapper.Handbrake --> HandBrake has exited.
–> Process exited with code 2
WARNING> 2017-11-09T22:43:35 MCEBuddy.AppWrapper.Handbrake --> Handbrake failed, non 0 return code
INFORMATION> 2017-11-09T22:43:35 MCEBuddy.AppWrapper.Handbrake --> QuickSync encoding supported available -> False
INFORMATION> 2017-11-09T22:43:35 MCEBuddy.AppWrapper.Handbrake --> H.264 encoding supported available -> False
INFORMATION> 2017-11-09T22:43:35 MCEBuddy.AppWrapper.Handbrake --> H.265 encoding supported available -> False
2017-11-09T22:43:35 MCEBuddy.Transcode.ConvertWithHandbrake --> Handbrake profile disable software encoder fallback after hardware encoding failure (handbrake-DisableSoftwareEncoderFallback) : False
2017-11-09T22:43:35 MCEBuddy.Transcode.ConvertWithHandbrake --> Handbrake profile optimized for hardware encoding, disable auto hardware optimization (handbrake-UsingHardwareEncoding) : False
2017-11-09T22:43:35 MCEBuddy.Transcode.ConvertWithHandbrake --> Cannot find supported h264/h265 software/hardware encoder combination in profile, disabling auto hardware encoder adjustments

Help!

Thanks,
Bret

Can you attach your conversion log file. There maybe more in there. Do you have a Nvidia graphics card?

I do have an Nvidia card, although it’s an older one. Here’s a link to an example conversion log file:
Conversion Log

I appreciate the help!!
Bret

Ok, after much reading, I’m GUESSING that MCEBuddy is shifting from Handbrake to ffmpeg so that it can use NVENC with my Nvidia card. I thought I had QSV, but because my motherboard video is disabled, it’s not available.

I’d love for someone to confirm that this is what’s happening.

Thanks!
Bret

So I did a quick test, and if I disabled “Hardware Encoding” then it uses Handbrake.

So what I can’t figure out is a) if it’s not using Handbrake normally because it can’t find QSV then b) why does it not seem to be using NVENC with ffmpeg (based on the log file above), even though it’s detected?

Is this usually just some weird issue with the drivers? I’m inclined to just disabled Hardware Encoding so that I can use Handbrake, but I’d love to understand it all first…

You got it! That’s exactly what’s happening on both counts. You can see the same in your log file where is detects Nvidia hardware and prefers your encoders.

You can:

  1. Disable reordering (see advanced commands)

  2. Disable hardware and encoding on expert settings page of the conversion task

  3. Enable your QSV intel video card as your primary card to use handbrake hardware encoding.

I am having the same issue but I can’t seem to find Disable hardware and encoding.

If you go into your conversion task and click “Advanced Settings” and scroll all the way to the bottom of the screen, you’ll find Expert Settings. If you click that, you’ll find a checkbox for “Hardware acceleration” about midway down the page.

1 Like