All profiles Capped at 2mbps?

I am trying to get a profile setup, first tried MKV HEVC, then tried MKV High Quality using NVENC on both. Everything is good accept there seems to be some sort of file limit or bitrate limit set. On both of these no matter what I do to the settings the bitrate is right at 2000 and the file size is about 500mb.

On the HEVC testing I went from cq 28 to 20, nothing changed.

Went to H264 and noticed -b 1800k which I assumed was the bitrate setting, but got basically the same file size/bitrate.

Some setting is overiding my settings and I have no idea what, can someone help? I am using ffmpeg to use NVENC,
Here is a log INFORMATION> --> Starting conversion - DEBUG MESSAGES INFORMATION> --> Windows - Pastebin.com

here is my HEVC profile

ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec h264_nvenc -b 3500k -x264opts me=hex:trellis=2:subq=8:partitions=all:8x8dct=1:ref=5:rc-lookahead=50:keyint=25:min-keyint=20:bframes=3:weightb=1:level=4.0:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=2:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip

I thought I had figured it out with the quality slider, but still my encode will not exceed 2000kbps, can someone please tell me what I am missing here, surely this isn’t a limitation of the software.

Looks like the profile configured to be used in your Conversion Task isn’t the same one you’re editing, which explains why nothing changes :slight_smile:

Check that each profile has a unique name. If you’re customizing profiles it’s better to create a new one with a unique name.

This is the one the Conversion Task has been configured to use (and it’s using crf and not bitrate)

INFORMATION> 2019-08-29T15:01:45 MCEBuddy.Engine.ConversionJob --> Converting
–> Profile being used : HEVC MKV
Profile entries ->
–> Description=HEVC in MKV (H.265/AC3) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
–> order=ffmpeg,handbrake
–> ffmpeg-general=-threads 0
–> ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec nvenc_hevc -preset slow -crf 20 -map 0:v -sn
–> ffmpeg-audio=-acodec ac3 -ab 160k -map 0:a
–> ffmpeg-audioac3=-acodec copy -map 0:a
–> ffmpeg-ext=.mkv
–> ffmpeg-audiodelay=skip
–> handbrake-general=–decomb --loose-anamorphic --verbose=2
–> handbrake-video=–start-at duration:0 -e x265 --encoder-preset slow -q 20
–> handbrake-audio=-E ffac3 -R auto -B 160 -D 0 -a 1,2,3,4,5
–> handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
–> handbrake-ext=.mkv
–> handbrake-audiodelay=skip
–> PreConversionCommercialRemover=true

Sorry I was testing so much I pasted the wrong profile. Here is the recent log with the profile used same problem.
And the same thing happens also with the profile you quoted. That’s my problem, it says q 20 but changing that value does nothing. Always 2000kbps. I am attaching the HEVC profile and log. Same problem, changing the quality does nothing, it is currently set at 25.

[HEVC MKV]
Description=HEVC in MKV (H.265/AC3) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
order=ffmpeg,handbrake
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec nvenc_hevc -preset slow -crf 25 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 160k -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
handbrake-general=--decomb --loose-anamorphic --verbose=2
handbrake-video=--start-at duration:0 -e x265 --encoder-preset slow -q 20
handbrake-audio=-E ffac3 -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mkv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

Log:
https://pastebin.com/8PUC69Bp

Hopefully that makes things clearer. I am not seeing anything there that would limit the bitrate but I have not been able to get the bitrate/filesize to budge.

(Sorry for all the posts)
I see this in the log, and I don’t know why its there, where it is being inserted.
Stream #0:1: Video: hevc (nvenc_hevc) (Main), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], q=-1–1, 2000 kb/s, 29.97 fps, 1k tbn, 29.97 tbc

Don’t know if this is what’s causing your problem, but - from your log.

[nvenc_hevc @ 000001f6b8970e60] This encoder is deprecated, use ‘hevc_nvenc’ instead

1 Like

Ok I can change that. I think it was the slider setting. I just don’t understand how the slider (quality slider) is meant to work with a fixed bitrate or a cq setting. I have adjusted the quality to -40% and I think I am happy with the results. So it is what it is I suppose.

Only tested at my desktop, need to compare on the TV and see how things look.

That’s because -cq is not recognized by MCEBuddy. It’s a deprecated option in ffmpeg and it doesn’t mean constant quality as most folks think. It means constant quantizer, very different from constant quality.

You should either use the -b for bitrate or -crf for quality. MCEBuddy recognizes both and will adjust the values when you move the slider.

If you don’t want MCEBuddy to change any of your video profile parameters (including ignoring the quality slider) add the necessary VideoOptimized directive to your profile. See this link for more details: MCEBuddy - Advanced Settings, Commands and Tweaking

When creating custom profiles refer to the above link and also feel free to check out existing profiles for examples.

Excellent, now we’re getting somewhere, thank you for responding, I will do some more testing, in ragrds to the post above should I change from nvenc_hevc to hevc_nvenc? Assuming those are different.

They’re the same but use the recommended option as mentioned by @zhulick as MCEBuddy uses the newer convention if you’re using any of the built options to manage hardware acceleration

Honestly I just took the HEVC profile and replaced what was there. Something like libvx265 with that. Trying to get her accel because just ticking the box didn’t work.

One thing that seems limited compared to the handbrake settings is the ability to use decomb and deinterlacing settings. At least I see it in HB and not ffmpeg.

Should I assume that all settings available for ffmpeg will work if I include them in the profile?

You don’t have to use ffmpeg if you’re more comfortable with handbrake. I personally prefer handbrake, so i use that.

just change the encoder to “–encoder nvenc_h265” (with no quotes) to trigger nvenc using handbrake cli.

Oh really? In all the documentation I found for mcebuddy (on this site) I swear it said Handbrake was quicksync only and ffmpeg was needed for Nvidia. That’s fantastic as I am more comfortable with handbrake and already have settings that I like. Just wanted to use HW Accel to free up the cpu.Thanks a lot.

You can definitely use handbrake. You may need to update the handbrake cli exe with the latest version (just replace the exe inside the handbrake forlder), not sure. When i first tried it a while back i remember having to do that. Not sure if the cli version included with mcebuddy has been updated since, it may have been.

I’m sorry that I have to be spoon fed here but for the life of me I can’t get it to trigger nvenc. I have tried 100 different combinations. Originally it said -e x265
That triggered software, but adding nvenc_h265 instead of x265 doesn’t work. Trying like you said doesn’t work, here’s my profile. also how do I set it to not touch the audio, just want to pass it through.

[HEVC Handbrake MKV]
Description=HEVC in MKV (H.265/AC3) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
order=handbrake
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec -e nvenc_hevc -preset slow -level 5.1 -b:v 3500k -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 160k -map 0:a
ffmpeg-audioac3=-acodec copy -map 0:a
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2
handbrake-video=–start-at duration:0 -encoder nvenc_h265 -preset slow -q 26
handbrake-audio=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mkv
handbrake-audiodelay=skip
handbrake-VideoOptimized=true
handbrake-UsingHardwareEncoding=true
PreConversionCommercialRemover=true

If you’re not using ffmpeg, you can delete all references to it from your profile.

Mine looks like this
[NVENC HEVC MP4 q22med/640]
Description=HEVC in MP4 (H.265/AAC) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
order=handbrake
handbrake-general=–loose-anamorphic --verbose=2 -f mp4 --subtitle “1,2,3,4,5”
handbrake-video=–start-at duration:0 --encoder nvenc_h265 --encoder-preset medium -q 22
handbrake-audio=-E eac3 -R auto -B 640 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

I use eac3/640 for audio, so change that back to aac/160 or whatever else you plan on using. If your output is mkv, change the extension to mkv and delete -f mp4 from general. Add -decomb - denoise if you need it to video.

If you leave handbrake-VideoOptimized=true in your profile, mcebuddy will treat the source as gospel and skip any video processing - so no noise removal etc. Great for when you’re converting a bluray rip, not sure if it’s good to have on for DVR’d tv episodes etc.

Thank you I will try it out. I like 640 audio but most of my tv stuff is 384 at best. So don’t want ti upconverting. Wanting to figure out how to just do passthrough.

EDIT Finally! Thanks man, I am so bad at syntax its terrible. I appreciate the help so much.

Still seems like the slider rules all, not sure what the point of CRF of -q would be with a slider overiding it. Even with the opitimized video thing it seems that the slider dictates what actually happens.

I think that’s the way it was meant to be. The sliders override the profile so users can adjust quality and size from the gui. Mcebuddy doesn’t know if you’re using one of its pre-baked accounts or one of your own, so it will override whatever settings it gets.

I’ve never used the slider, so i don’t know how accurate it is. That said, if i were to use one, i would set up my profile with a -q of 20 first. This way a +10% bump would equal -q22, +15% is -q23 etc. This way at least i have an idea of approximately which -q i am at. Again, no idea how the percentages on the slider correspond to the actual increases in -q, but in theory it should work.