Customizing my Profiles.conf

Hi what seems simple after many google searches I cannot find the answer.

I wish to make these files 720p while converting.

Am I dreaming or can I just add a couple of lines here?

[HEVC MP4]
Description=HEVC in MP4 (H.265/AAC) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 26 -map 0:v -sn
ffmpeg-audio=-acodec libfdk_aac -ab 128k -cutoff 18000 -map 0:a
ffmpeg-audioac3=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2 -f mp4
handbrake-video=–start-at duration:0 -e x265 --encoder-preset medium -q 26
handbrake-audio=-E faac -R auto -B 128 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

[----------------------]

You can try using the following line in your profile but the change in bitrate will lead to a loss in quality so you will have to adjust the CRF value to a lower number. If you are using hardware acceleration you will have to write a whole new profile for the video as this is a software profile.

You are basically adding the “Video Filter” -vf scale=-1:720

ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vf scale=-1:720 -vcodec libx265 -preset medium -crf 26 -map 0:v -sn

You will also have to change the order to put ffmpeg first and then just delete everything that says Handbrake since ffmpeg is superior in my opinion.

I have not tried this but I found the information online. If you are using hardware encoding then let me know and I will try to help you. I have just learned this myself so I am new to custom profiles too.

Thanks Ronald,

I have added and will see how it goes.
No luck.
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:BPS, Value:192000
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:DURATION, Value:01:01:31.520000000
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:NUMBER_OF_FRAMES, Value:115360
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:NUMBER_OF_BYTES, Value:88596480
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_WRITING_APP, Value:mkvmerge v53.0.0 (‘Fool’s Gold’) 64-bit
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_WRITING_DATE_UTC, Value:2021-03-14 21:01:30
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_TAGS, Value:BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:BPS, Value:8496220
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:DURATION, Value:01:01:31.560000000
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:NUMBER_OF_FRAMES, Value:184578
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:NUMBER_OF_BYTES, Value:3920538568
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_WRITING_APP, Value:mkvmerge v53.0.0 (‘Fool’s Gold’) 64-bit
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_WRITING_DATE_UTC, Value:2021-03-14 21:01:30
WARNING> 2021-03-17T20:58:34 MCEBuddy.MetaData.VideoMetaData → Unknown MKV tag, Tag:_STATISTICS_TAGS, Value:BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
WARNING> 2021-03-17T20:58:36 MCEBuddy.MetaData.VideoMetaData → TV.com failed
ERROR> 2021-03-17T21:00:18 MCEBuddy.Engine.ConversionJob → Unhanded error during conversion, conversion cancelled
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at MCEBuddy.Transcode.Convert.GetConversionExtension(ConversionJobOptions conversionOptions)
at MCEBuddy.Engine.ConversionJob.GetDestinationFilename(ConversionJobOptions conversionOptions, VideoMetaData metaData, String originalFileName, Log jobLog)
at MCEBuddy.Engine.ConversionJob.Convert()

Have you tried setting the maximum resolution slider to 720 in the conversion task settings?

Hello Goose,

Makes sense and will try.
:+1:

The slider is max width. The OP is looking for a fixed max height. The right CLI options in the config are the way to go. Handbrake has its own 720p preset profiles that you can specify if ffmpeg doesn’t.

You also should be sure you’re not upscaling SD content. That’s best left to your TV. Unless there’s some broken letterboxing going on with the source and you need upscaling and cropping. However, the picture won’t get better with recompression.

Hi Mike

I think what u r saying is what I want ! :+1: :-1:

So what is the Handbrake 720p profile line that I put in the config ?

You create your own profile for 720p and then use the profile option by the name you gave your profile.

It’s best to install Handbrake standalone and use the gui to set the profile. Then transfer the profile settings to the MCEBuddy CLI version so when you in invoke it in MCEBuddy config, it will find it.

You might be able to do it directly from the Handbrake CLI options in the MCEBuddy config - the documentation site at Handbrake.fr will have the details.

Thanks mike.

I have created a new section in the profiles.conf named [HEVC new 720p Profile MP4] .

What I am asking is What and where do I put the 720p line in this section.

Do I put a 720p command in place of the bold line
What is that line ?
I have handbrake and have googled the command but have had no success.

I usually exhaust all options before I come to the developers forum …

[HEVC new 720p Profile MP4]
Description=HEVC in MP4 (H.265/AAC) conversion. Creates a smaller file (50% smaller than H.264) with comparable quality but very slow.
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 0 -vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -crf 26 -map 0:v -sn
ffmpeg-audio=-acodec libfdk_aac -ab 128k -cutoff 18000 -map 0:a
ffmpeg-audioac3=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=–decomb --loose-anamorphic --verbose=2 -f mp4
handbrake-video=–start-at duration:0 -e x265 --encoder-preset medium -q 26
handbrake-audio=-E faac -R auto -B 128 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

[----------------------]

Find MCEBuddy’s HandbrakeCLI.exe and run it with the -h option.

Or, read here:
https://handbrake.fr/docs/en/latest/cli/command-line-reference.html

You probably want the “–height 720” option, and the “–no-interlace” option (i.e. progressive).

Or if it is in your preset, you can export the GUI presets and then import just your custom preset and then specify it. The preset export should basically be the options you’ve setup in the GUI, as a JSON file instead of a big long list of options.

If you prefer listing the options, vs a preset config, ok.

Thanks Mike

You are trying to be helpful but I have tried Importing exporting copy and paste , credted .json files, anything that might do what i want.

I want THIS line handbrake-video=–start-at duration:0 -e x265 --encoder-preset medium -q 26
but with 720p in it somewhere

So if you cannot give me that line that i have asked for several times STOP REPLYING. :stuck_out_tongue_closed_eyes:

I have given you the option you need to add to the config line.

There is a “–height” option. Use it. You’re welcome for the help I offered and my time.

READ THE FINE MANUAL in the alternative.

If that fails, what I told you to do works for me, so the problem must be you. :stuck_out_tongue_winking_eye: