Confused by CLI behavior

Hi all,

I had an unwanted server migration due to a hardware failure. As I’ve been rebuilding the server (now on proxmox), I’m running into a weird issue.

I’ve mounted the shared drive as “w:”

When I try running my plex post-processing script, the script exits nearly immediately. When I try running the UserCLI command line against one of the files I want to convert, I get the following:

C:\PROGRA~1\MCEBuddy2x>MCEBuddy.UserCLI.exe --command=addfile --action="W:\_TV\TV-NoCommercials\Washington Week (2012)\Season 55\Washington Week (2012) - S55E18 - Washington Week.ts"

MCEBuddy.UserCLI is a Command Line Interface for users to interact with the MCEBuddy engine
Copyright (c) RBoy, Build Version :
Build Date : 10/12/2022 16:13:48

MCEBuddy.UserCLI trying to connect to Engine localhost on Port 23332

MCEBuddy.UserCLI successfully connected to MCEBuddy engine
MCEBuddy.UserCLI processing command addfile
MCEBuddy.UserCLI adding file W:\_TV\TV-NoCommercials\Washington Week (2012)\Season 55\Washington Week (2012) - S55E18 - Washington Week.ts to the conversion queue
WARNING> Networked files will be accessed using the logon credentials of the MCEBuddy Service, not the currently logged on user. You can manually specify the network credentials from the Settings -> Expert Settings page in MCEBuddy.

MCEBuddy.UserCLI Successful!!

I’ve set the right user and password in the expert system settings. Regardless, since the drive is mapped, why do the credentials come into play at all. Help! Thanks! Will.

See the third FAQ on this page as to why credentials are required

yeah - I’ve set both the network credentials and am running the command line engine vs the service. I think it’s because I was mapping different points of the NAS as different drive letter. Getting rid of that and going to a single mapped drive fixed it. As you say in the guide, windows is VERY FINCKY about this stuff :slight_smile: