[BUG] How to avoid commentary/narration channels


(Matt) #1

So I have tried everything to select the different audio tracks. i followed MCEBuddy 2.x - Suggested profile changes to avoid commentary/narration channels in 2.4.3 but did not have any luck. i also have an english and spanish track where spanish is the commentary but no matter what i do the mcebuddy always selects spanish. Any ideas? i am using 2.4.7


(RBoy) #2

Can you upload your “original” video and conversion log the server. Maybe we can find a way to improve the algorithm to detect narration tracks and avoid them.


(Matt) #3

I don’t mind uploading the file but it is very large. I was able to solve it by selecting the unmasking the select best soundtrack then setting the audio language to default. I just don’t understand why when I selected English that it would default to Spanish.


(RBoy) #4

That’s what we want to understand and samples help. Sometimes audio tracks language names don’t match the language and we’re trying to see if there are other ways to inserting narative tracks. You can do this, there is a file splitter below. Use it to cut the first 100MB of the file and then upload chunk 0 of the split file to the server.

http://www.mcebuddy2x.com/MCEBUDDY/File%20Splitter.exe


(Matt) #5

I tried using this splitter but it says please choose correct source file when I use it. Is it because it is a .ts file?


(Matt) #6

Ok i figured out a different method. hopefully that works. The link is ftp://upload.mcebuddy2x.com/mgranger/


(RBoy) #7

No that’s because you probably forgot to select the file :slight_smile: (you likely selected the destination folder for the split files but didn’t the source file name/path)

I see you split it using 7Zip but without the remaining pieces the file can’t be unzipped.

Do try the File splitter again.


(Matt) #8

No I selected the source file. I tried again and i get the same error


(RBoy) #9

Hmm it’s working fine here. Only thing I can think of is the file is locked by something process. Try making a copy of the file and then splitting it.


(RBoy) #10

Otherwise if you can just upload the entire file.


(Matt) #11

Ok it should be uploaded now. I figured it out. I had to copy the file to a new location and it worked.


(RBoy) #12

Thanks for the file, we tested it with the default MP4 profile and default settings and it’s selecting the correct english 5.1 audio track and ignoring the spanish/impaired track. Worked perfectly with ffmpeg and handbrake.

I’m guessing you either have a custom profile or a setting which is interfering with the default audio track selection. If you attach your log file I can investigate it further and let you know what’s happening.

However, your solution is correct, for whatever reason if wrong audio track is being picked, you need to uncheck the Select best soundtrack option in the Conversion Task -> Advanced Settings and then manually enter the track language / select from the drop down list that you want mcebuddy to select.

NOTE: that often the track language name doesn’t match what you hear. To find the list of audio tracks, add the file to the MCEBuddy conversion queue and then right click on it and select Info. That will give you the list of audio track and then language names. Use the name to select from the list of language names in the conversion task setting.


(Matt) #13

Well I just put my settings back to where they were and converted the small file and it seemed to work as well. I will try converting the large file again to see if that one is still failing. If it does I will upload the whole file. If it doesn’t fail then I will assume it is fixed somehow.


(Matt) #14

Ok so when i used the big file it didn’t work. i will upload the large file. if you go about 6 min 10 seconds in then you will find the commentary audio.


(RBoy) #15

It’s working just fine using the stock out of the box settings and MP4 Normal profile, it ignore the imparired/narrative audio track and selected the 5.1 Dolby track

I suspect it’s your settings or probably profile causing the issue.


(Matt) #16

I attached my log. Would you mind just taking a quick look at it and seeing if you see anything strange. Thanks so much for your help. I greatly appreciate it


(RBoy) #17

I don’t see any attachments to your post.


(Matt) #18

I uploaded it with the video file


(RBoy) #19

No, I only see mcebuddy.log, we need the conversion log for that specific file conversion


(Matt) #20

ok it should be there now