Audio Description Picked Up During Conversion?

There have been several occurrences (none recently that I have logs for) where I am transcoding a recording, and when the new video file is played, the primary audio channel has been replaced with the audio descriptions for the blind. This may be great for some, but it makes the show unwatchable in its original form. Strangely, the problem seems to be quite random – transcoding will work fine, and then two shows transcoded on the same day will switch the audio channel, and then no more will do that for some time. Is anyone else seeing this?

My workaround right now is to simply delete the transcoded show and watch it in the original Media Center format on the TV hooked up there, but I would like to understand better exactly what it is doing and why this might occur. (If I need to wait for one to actually happen again and post logs, then I can wait and re-open this later.)

If you can attach your conversion logs for the 2 conversions, the one that selects the correct track and one that doesn’t, I can see what’s going on. MCEBuddy tries to pick the best track (if you’ve selected the option for Choose best track) based on various parameters but sometimes if the metadata describing the track is incorrect it can cause issues. The logs will show the details.

Thanks for taking a peek. I finally have two conversions which ran on the same day (and were even from the
same broadcast channel). The first, Ghosts_UK, transcoded the descriptive audio channel. The second, NCIS_Sydney, transcoded the “normal” audio channel. I did pipe them through Beyond Compare and didn’t see anything obviously different, but admittedly, my experience with reading these logs is limited. (8.7 KB)
I do still have the original WTV file, if you need any details from that. Hopefully, you can see what I am missing. Talk to me, Goose!

You’ll need to set your log to Debug in the Settings → System settings page and then rerun the conversions. The currently log level doesn’t provide any insight into what’s going on. Feel free to upload the original WTV video files to the server and I can take a look at then to see what’s going on.

OK. Here’s the DEBUG log for you. Looks like it is picking Audio Channel 0, which is a MONO stream, over 1 (5.1 Surround). Let me know if you want to see the entire source file, and I can upload it.
Ghosts UK_WMEUCD3_2023_12_07_19_57_00.wtv-Convert to MP4-2023-12-15T11-01-44.log (4.6 MB)

I did opt to upload the files, along with a second show from 12/14 that ran OK.
Let me know if you see what I see.

Thanks, I was able to replicate the issue. I see what’s going on, the profile you’re using uses Handbrake and handbrake is picking the 1st audio track by default (which in this video has the mono audio). I’ll see if we can addresses it in the next release.

Meanwhile, you have 2 options

  1. Turn off the Select best Audio track option, in this case you’ll have all the audio tracks in the output file (the mono and the 6 channel audio)
  2. Edit your profile in the order line, change the first encoder from handbrake to ffmpeg and this will solve the issue

Thank you for your efforts, kind sir! The product is so good that I have only ever used a default install, so I’ve not even looked any further at the special configuration options.

I opted to make several changes: Put FFMPEG first, leave all audio tracks in the file, and NOT drop the audio to straight stereo (from 5.1). When I re-transcoded the file, the default audio track was still the Track 0 (mono with descriptions for the visually impaired), but I was able to change the audio track and select the full 5.1 surround track from the TV when I started running it there.

We just use this for recording TV shows and watching them at our leisure from any TV in the house, so we’ve never really worried too much about it, but perhaps it is worth spending a bit more time digging through the various options and seeing what kind of magic can be done.

This has been addressed in today’s 2.6.2 beta build. It will now automatically select the best audio track even when using handbrake.