Audio track missing/stripped from conversion

hdhomerun

(Matt) #21

uploading a full recording from last night also


(Goose) #22

I checked out your video, there’s definitely some issue with the video. I can’t even get it to play with WMP or some other players. While we’re looking into how MCEBuddy can repair the broken video/audio stream, you should look into why your recording device is creating a non compliant video with errors in it. That would be your best fix, even if MCEBuddy can repair these errors, there may be some uncoverable losses.


(Matt) #23

Thank you for your help! I never tried to play it back on anything than Emby or HPC-HC and they both played back fine. I tried on VLC and media center and saw issues. Since I have had this issue using HDHomeRun - EXTEND and the dual I can rule out hardware, and the issue is with all stations that only leaves Emby. I open a support ticket with them. Thanks again!


(Matt) #24

FYI I had the DVR in Emby set to “automatically convert recordings to a streaming-friendly format”. Removing that setting fixed the issue and MCEbuddy work great now!!


Conversion failing after upgrade from release 4 to 8
(Goose) #25

Emby was creating a file with invalid audio properties, here are some the issues various different tools discovered (from ffmpeg to handbrake to avidemux)

2018-02-09T18:02:14 MCEBuddy.AppWrapper.FFmpeg --> [mpegts @ 0000000000704740] Could not find codec parameters for stream 0 (Audio: aac (LC) ([15][0][0][0] / 0x000F), 0 channels, fltp, 326 kb/s): unspecified sample rate

2018-02-09T17:54:28 MCEBuddy.AppWrapper.AVIDemux --> [adm_lavLogCallback] 22:54:28-975 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.

Looks like the streaming friendly format was creating a non compliant video.