Adverts/commercials not being removed

I bought this software for the specific purpose of removing adverts in recorded TV shows, but I am completely unable to get it to do so. I am using Comskip. I have read several threads on the subject, with various helpful responses suggesting different settings in the INI file (this one seemed the most promising: Comskip.ini help) and have tried many, against several different shows. Whilst some of the settings succeeded in removing the adverts before the show starts, none has succeeded in removing the ones in the middle.

I am in the UK, and all of the shows I have tried were recorded from the channel Dave. The one post I found that specifically mentioned the UK had no responses, so I am wondering if this just does not work on our TV broadcasts. If that is the case then I would obviously expect to be refunded for the purchase.

Can anyone advise, please?

Ofcom, the regulator for the communications services in the UK, states,
Broadcasters must ensure that television advertising and teleshopping is readily recognisable and distinguishable from editorial content and kept distinct from other parts of the programme service. This shall be done by optical (including spatial) means; acoustic signals may also be used as well.

Unfortunately, every main owner of channels does the breaks differently.

In Comskip, detection level 111 seems to work for UK tv as a generic setting. Did you try to use Showanalyzer for commercial detection?

MythTV has an entire section dedicated to UKTV and Comskip.(Commercial detection in the UK - MythTV Official Wiki)

Comskip themselves may be able to give you help. Comskip Support Forum - Index page

Many thanks for your response, Paul @p37307. I have read the MythTV article, and I think I might be further away from a solution than I was before! I noted in particular the sentence when describing More4:

Most shows have a More4 logo always displayed in the top left which disappears during the ad breaks. The logo is semi-transparent and unfortunately doesn’t get detected.

I think that exactly the same would apply to the Dave shows that I have been attempting.

I’m afraid I can’t work out how to set the ‘detection level’ you mention. I can’t find it as a setting in the comcheck ini file; is it actually MCEBuddy itself? And that really is the problem here. I am an IT specialist, so I’m used to quite technical language, but this is a long way from my area of specialism, and I am struggling with the minutiae of the configuration. I now understand the reasons for the complications, but this is quite a long way from the ease of use which is suggested by the MCEBuddy home page. I was expecting this to be something I could essentially fire and forget, and I don’t have the time at the moment to continue experimenting with something that may ultimately even prove to be fruitless.

(I did also try Showanalyzer briefly, and that also failed to work, but only on default settings).

Thanks again.