2.5.7: Subtitles are lost during conversion

Hi all!

I did check extract subtitles :
image

And add subtitles :
image

However, the final file has no subtitles. The original file has a few language available.

Here’s the log.

Die Hard (2007) BD Ripp x264 1080p VF VOSTFR-HDZ.mkv-HEVC MKV-2022-11-12T09-07-31.log (3,0 Mo)

You’ve set the Audio language to Original (qaa) in your Conversion task settings page so it’s ignoring the other language subtitles (it synchronizes the audio and subtitle language).

2022-11-12T09:09:26 MCEBuddy.Transcode.CCandSubtitles → Found 3 Subtitle tracks, extracting tracks with languages: qaa
WARNING> 2022-11-12T09:09:26 MCEBuddy.Transcode.CCandSubtitles → Skipping subtitle extraction since subtitle language >fre< is NOT in the subtitle language list
WARNING> 2022-11-12T09:09:26 MCEBuddy.Transcode.CCandSubtitles → Skipping subtitle extraction since subtitle language >fre< is NOT in the subtitle language list
WARNING> 2022-11-12T09:09:26 MCEBuddy.Transcode.CCandSubtitles → Skipping subtitle extraction since subtitle language >eng< is NOT in the subtitle language list

Reset to <default> (or one of the languages present e.g. eng) and it’ll process all the subtitles

image

Thanks! It worked.

Quick question though: is it possible to keep only fre+eng+other original ? That is valid for the audio also.

Though in this one all subtitles were lost. Can you help me find why?
Assassin’s Creed 2016 4k 10 Bits FR EN X265 DTS-mHDgz.mkv-HEVC-2022-11-29T11-38-26.log (7,4 Mo)

Thanks!