Using MCEBuddy with Playon (Hulu channel)

I’ve been trying different options with both Comskip and Showanalyzer in hopes of removing commercials from my recordings but I seem to have no luck.

The “only detect ads” is unchecked and Playon doesn’t seem to place chapters for Hulu.

Showanalyzer does create a .xml file with timing of the commercials with a new recording but doesn’t remove the commercials within it.

Kevin From Work - s01e03 - Who’s Your Friend From Work.mp4-comskip-2019-04-11T19-08-43.1894994-04-00.log (466.9 KB)
Kevin From Work - s01e03 - Who’s Your Friend From Work.mp4-ShowAnalyzer-2019-04-11T19-12-13.5404006-04-00.log (425.4 KB)

Comskip and ShowAnalzer didn’t find any commercial segments greater than 20 seconds (default minimum commercial detection size required by MCEBuddy, this can be adjusted through the System Settings page)

ConvertCutListToKeepList: Keep segment Start:0.000 Stop:0.517 --> ConvertCutListToKeepList: Keep segment Start:6.818 Stop:1291.480 --> ConvertCutListToKeepList: Keep end segment Start:1296.050 Stop:1297.276 --> ConvertKeepListToCutList: Skip segment, too small Start:0.000 Stop:0.000 --> ConvertKeepListToCutList: Skip segment, too small Start:0.517 Stop:6.818 --> ConvertKeepListToCutList: Skip segment, too small Start:1291.480 Stop:1296.050 --> ConvertKeepListToCutList: Skip end segment, too small Start:1297.276 Stop:1297.276 --> ConvertKeepListToCutList Done WARNING> 2019-04-11T19:16:46 MCEBuddy.CommercialScan.Scanner --> Empty EDL file detected

If there are longer commercials, you will need to tweak your commercial detection settings to make it more aggressive. Tuning Comskip and Custom Comskip INI's (Country / Channel specific)

Thank you Goose for replying!

So I adjusted for shorter commercial segments within MCEBuddy so that they would be deleted and it does work.

It ended up causing an audio delay with the edited video but I noticed a suggestion of using MP4 Normal profile which indeed fixed that issue.

When I watch the video though it seems that a very small bit of the advertisement is left in the final video, (less than a second at every cut). I was hoping there’s some way of making the edit more clean? I’ve adjusted ShowAnalyzer min/max check spacing and missing logo forgiveness time all the way to 1e-005 with the same result.

You can can configure comskip to do it, see the comskip tuning page and the Comskip INI Editor Tool to see how to adjust the ini file to cut an additional X seconds of each commercial segment identified.

Similarly for ShowAnalyzer, you can use the GUI configuration that ships with the tool to edit the settings.