Successful conversion, but no video

Hi all,

I’ve run into an issue where the log file says the video has been successfully converted, but there’s no video in the resulting file. What’s weirder, it seems like it only happens with TV shows with 60 FPS.

Log for encode:!AipRNNbyPsCgn4cO-kqRvTj2aR5Q2g

Thanks! Will.

Nevermind - I think I figured it out…

I’m having the same problem… What did you figure out?

It has to do with the mapping of the streams to the vodecs. Some video files seem to allow MCEBuddy to automatically map, and others to not, causing a failure (no video).

I solved it with this encoding profile:

    [MKV HVEC Constant Quality]
    Description=WARNING: Handbrake Constant Quality encoding (25) with Nvidia HVEC.
    order=ffmpeg, handbrake
    ffmpeg-general=-threads 0 -hwaccel auto
    ffmpeg-video=-ss 9 -c:v hevc_nvenc -crf 25 -map 0:v
    ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
    ffmpeg-audioac3=-acodec ac3 -ab 384k -map 0:a
    handbrake-general=--decomb --denoise="weak" --loose-anamorphic --verbose=2 -T -O
    handbrake-video=--start-at duration:3 -e x265 -q 18 
    handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
    handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5

It’s the “-map 0:v” and “map 0:a” that solved it for me. When I looked through the encoding logs, it kept saying something to the effect of “I don’t know what to do with this video stream so I’m not going to encode it.”

Hope it helps! Will.

1 Like

All of MCEBuddy’s profile come with map 0:v in them by default. We added this to the profiles quite some time ago because MCEBuddy now supports files with multiple video streams. At runtime, MCEBuddy will replace this parameter with the actual stream number it discovers in the file (it takes the first video stream and ignores the alternative). I can see why you would have trouble with a profile without this parameter.

Similarly all audio-<encoder> parameters should contains map 0:a as well in them and MCEBuddy will take care it from there.