HW encoding not detected

Hi,
Recently decided to play around with MCEBuddy to try and speed up my TV recording processing. As I understand, recordings are formated as h264 and AC3 so all I really need is to make it an mp4/mkv, subs extracted and comercials cutted. I’ve been using ffmpeg quite a bit recently and decided to test a few things with “codec copy”. So after testing a few files manually I realised I only had to manipulate a profile to specifically do this. I’ve configured a profile in MCE and tested - which worked ok - but found a few issues in the logs:

I have just put together this new PC with a Gen 10 core i5 processor, still using my old GT630 card (waiting for a new one). I noticed HW encoding is not detected
Also, even having ffmpeg as the first option, it tries to use handbrake first before failing.

What’s wrong with my config or where should I look?
Anything else wrong with my config? I want to ignore handbrake or at least have similar “codec copy” as the fallback

log uploaded : MCEBuddyLog - Pastebin.com

ok, a bit more digging and of course, somehow my internal graphic was disabled since I had the additional card. Sorted that out and now it does recognise the intel HW
QuickSync encoding support available -> True
H.264 encoding support available -> True
H.265 encoding support available -> True
But further down it’s still trying to do handbrake first, and now failing with this message (repeating multiple times):

MCEBuddy.AppWrapper.Handbrake --> [h264_qsv @ 0000000002eb3b40] Error initializing the MFX video decoder: unsupported (-3)

how do I force ffmpeg?

more to my story
to achieve what I’m after, removed any backup option (not sure how good or bad this is) and left only FFMPEG. Also added:
ffmpeg-general=-threads 0 -hwaccel qsv
So now it runs the conversion really FAST! happy with that.
Note this works for me because I know the source is h264/ac3 from free to air TV, compatible with my Plex setup. And for me these are throw away recordings.

I guess the outstanding question is if there’s a better way to achieve this?
maybe some way of ffmpeg to know there’s hw transcoding available and add that parameter automatically?

Please set your logs to debug. I can’t tell much from your current logs.