Start Trim not to Keyframe, causing "no video" on output

Happy to @Goose - PM me details on where to upload the files and logs, and I’ll get them in your hands immediately.

have updated ffmpeg - doesn’t seem to help.

Upload instructions are here: Welcome to MCEBuddy - README BEFORE POSTING

:man_facepalming:

Will get it done. :slight_smile:

** uploaded as request - appreciate the time **

Just joined so I can add to this. Glad I found this thread, i am experiencing the same issue. It is related for me to PlayonCloud recordings. I think something changed on their side, because I can take recordings I did about a month ago on playon and run it through MCEBuddy and no issues. The Skip Remuxing Files does not work for me, causes the audio to be delayed. however removing the cut start, it does work, you just have the playon intro now

1 Like

FWIW, I can make them cut right in FFMPEG by hand if I use MP4 or MKV instead,

ffmpeg -ss $TRIM_DURATION -noaccurate_seek -i "$INPUT_FILENAME" -avoid_negative_ts make_zero -map 0 -c copy "$OUTPUT_FILENAME"

+1 to what @toadman mentioned. I too can repro this with when I add a “Start Cut” and “End Cut” on PlayOn recordings. Does not repro with live TV recordings of the same show (WMC / .wtv).

This occurs on 2 separate machines with one being older HW and another being newer HW. Same failure when converting to HVEC, MP4 or no conversion. Both machines were working successfully a couple weeks ago with no other changes other listed above.

Let me know if uploading any log files or recordings will help.

@dlasher let me know if this isn’t the same issue you are seeing, I don’t want to hijack your thread with an alternate issue.

Exactly the same issue, videos sourced from PlayOn, thanks for checking @schnood

I thought I would post what I think is another example. I went ahead and uploaded the log files to the mcebuddy server if helpful. Similar to a few others, when processing a Playon Cloud recording with a Cut Start, it does not show a video after processing. Running it a second time without a Cut, and it processes & plays fine. For kicks, I re-ran a Playon file from the desktop version (v4.5) with a Cut Start of 4 seconds and it plays back fine.

References for the uploaded log files (also zipped here):
Log files.zip (695.1 KB)

Log # 1: is from a Playon Cloud recording, with a Cut Start of 6 seconds. After it processes, no video shows.

Log # 2: This log is from the same source file, but with no cut. It processes & plays back fine

Log # 3: This log is from Playon – desktop version (a few months ago, using v4.5). I set it up with Cut Start of 4 seconds, and it processes and plays back fine.

@Goose is there any additional info that would help? Is this on the books as an “official” issue?

I am also having the same issue.

Here is some more information on the issue and a circumvention.

I had a TV show that was recorded using Playon.

I took the .mp4 and using a file converter tool converted it to .mp4 (with the idea that this would add any segments missing from the original that MCEBuddy is having problems with).

I then had MCEBuddy remove the first and last 5 seconds.

This worked fine.

I then had MCEBuddy remove all commercials using the Comskip option.

This worked fine.

It appears that Playon has changed to no longer write all the segments that MCEBuddy is expecting.

Until this is fixed, I will be following this process.

I hope this helps others.

Thanks for the logs and sample files. It appears that the MP4 file being produced by the latest version of PlayOn isn’t compliant with the specs and has errors which is throwing ffmpeg off when it tries to remux it from MP4 to TS for processing the file AND while trying to trim the start. During this process it’s losing some critical metadata about the video stream so it can’t be played back.

The short term solution is to enable the option to enable the option Skip remuxing files in the Conversion Task → Expert settings page to avoid having MCEBuddy remuxing the MP4 to TS and instead work directly on the MP4 files - which should avoid this issue.

The long term solution is to report it to PlayOn so they can fix it, as @scott_mb has tested that it’s working fine with PlayOn version 4.5

Anyone on this group going to contact playon?

I contacted Playon support. Since the original videos are playable, they are not treating this as a bug on their side.

Well that’s disappointing but not surprising.

Digging deeper into what’s going on, there’s definitely an issue with their MP4 files being created by the new software. If you want you can run their MP4’s through a software called MP4 inspector and if the MP4 is compliant with the specs it’ll give you a clean chit. In this case the recording uploaded by you showed that the MP4 file created has a problem with the moov atom structure. The moov atoms are critical to MP4’s because they contains all the information about what to find where and how it should work. In this case since PlayOn is creating a defective MP4 moov structure when ffmpeg (and MP4 Inspector) accesses that information it’s can’t get what it needs causing the video stream to drop out (infact ffmpeg also complains about missing video metadata after trying to cut a few seconds because it needs that information to resynchronize the video stream after cutting).

Here’s the output from MP4 inspector showing the defective MP4 moov atom structures. Maybe this will help PlayOn relook at their answer.

I will go ahead and send the information on to Playon and keep everyone on this thread informed.

I am not surprised by PlayOn considering it not a bug. For some interesting reading go read the Reddit r/playon there is years and years of neglect and complaints about the games they play. They are not a large company at all.

Hey, so tried some PlayOn sourced video today, with MCEBuddy 2.5r7, and it appears to handle the video files correctly when you clip at the start/end…

Captions are preserved, “Skip Remuxing” is OFF, so I’m calling success here!

Rather than expect that they fixed anything, I’m going to go out on a limb and thank @Goose for a bugfix/work-around. Much appreciated!

Playon has not responded. Because of that, I went ahead and started using a different tool than Playon that doesn’t have the problem.