Remuxed from TS to MKV with incorrect video length

Hey there, normally I only use MCEBuddy for a single custom rename and commercial removal from one or two shows that I keep for re-watching. It works just fine but recently started watching on a device that doesn’t want to let me fast forward MPEG2 in a TS container so I decided to let MCEBuddy remux everything to MKV.

Last night it remuxed about 180 files and most were fine except a handful that came back with new length that was wildly incorrect. If I run one of these same files through MKVMerge for remux they turn out fine. Attached a log file where you can see original duration is detected correctly several times as 43 mins 07 seconds but right towards the end it’s now 13 hours 43 mins and 07 seconds.

I tried scanning back a few pages here to see if anyone else was having an issue but couldn’t find anything. Any thoughts?


Law & Order S20E06 Human Flesh Search Engine.ts-Comskip-2018-04-08T06-59-29.4923358-05-00.log (286.5 KB)

I’m starting to think it’s an issue perhaps due to signal drop outs during weak OTA reception at time of recording. The remuxed files done by MKVMerge have the correct duration but also exhibiting A/V sync issues at the end of the file. I didn’t watch the MCEBuddy remuxed files long enough to see if true for both.

MCEBuddy isnt’ using MKVMerge, it’s using ffmpeg to create your MKV files. From your profile:


It’s setup to use ffmpeg as your encoder and ffmpeg is directly encoding it to mkv.

If you want it to use mkvmerge then modify the profile like this:


This will have ffmpeg create a MP4 file and then use MKVMerge to remux it to a MKV.