NVIDIA, MCEBuddy or Comskip?

I’m having an issue that I cannot figure out if it’s related to my Nvidia, MCEBuddy or Comskip setup. I’m recording 1 hour TV shows on my laptop with Happauge’s HD PVR 2. It records shows in H.264 format (which I’ve confirmed is the codec when I view the media information within MCEBuddy), although when I view the properties of the file it states it’s a MPEG-2 TS Video (.ts) file. I’m running Windows 7 Pro 64 bit, my processor is an Intel Core i5-3230M CPU 2.6GHz and I have a dedicated NVIDIA NVS 5200M Graphics card along with the standard Intel HD Graphics 4000. I’m currently using MCEBuddy version 2.4.8 and paid the $10 to get the Donator version (0.82.003), but understand now that I didn’t need to pay the $10 because MCEBuddy Version 2.4.8 comes with the Donator version.

After reading several posts in these forums I set up MCEBuddy in the following manner. In the Nvidia Control Panel I have MCEBuddy set to use High-performance NVIDIA processor to take advantage of my graphics card, rather than using the standard Intel HD Graphics 4000. Inititally this helped a great deal as it decrease the entire processing time down from 6 hours to 2.5 hours.
image

When I converted my first file, using this setup, the log file shows the Advertisement Scan at 36 minutes, Removing Commercials at 5 minutes and Converting at 1 Hour 39 Minutes. The total time of 2.5 hours was better than my initial 6 hours, but I’ve read where some people have converted a 1 hour program in 15-20 minutes. I’ve attached the log file for this conversion and have named it File 1.

I then tried the Donator version of Comskip and saved it to it’s own folder and in the MCEBuddy System settings I have it pointing to that folder.

When I converted another 1 hour TV show it flipped the processing time between the Advertisement Scan and Converting. The log file shows the Advertisement Scan at 1 Hour 30 Minutes, Removing Commercials at 5 minutes and Convertings at 46 minutes. The entire process took 2 hours 41 minutes. I’ve attached the log file for this conversion and have named it File 2.File 1.log (2.1 MB)
*Update: the log file I’ve named File 2 is 70.5MB and it won’t allow me to upload. This is another odd thing as the size of my File 1 log is only 2MB.

I’m at a loss as to what to try next? Is it my setup or is it the fact that H.264 files take longer to process? Would I be better served to convert the H.264 to MP4 first, using a different program, and then run it through MCEBuddy to remove the commercials? Any assistance anyone can offer would be greatly appreciated. Thank You

Zip and upload

Most likely where the scanning time increase you used the free version of comskip (not donator). Can you verify this from the logs. Common mistake.

As for the conversion, it’s not using your nvidia hardware because it can’t detect it:

2018-02-23T20:28:36 MCEBuddy.AppWrapper.NVidiaQuery --> C:\Program Files\MCEBuddy2x\nvidia\nvidiaQuery.exe Starting…
2018-02-23T20:28:36 MCEBuddy.AppWrapper.NVidiaQuery --> CUDA Device Query (Runtime API) version (CUDART static linking)
2018-02-23T20:28:36 MCEBuddy.AppWrapper.NVidiaQuery --> cudaGetDeviceCount returned 30
2018-02-23T20:28:36 MCEBuddy.AppWrapper.NVidiaQuery --> -> unknown error
2018-02-23T20:28:36 MCEBuddy.AppWrapper.NVidiaQuery --> Result = FAIL
–> Process exited with code 1
WARNING> 2018-02-23T20:28:38 MCEBuddy.AppWrapper.NVidiaQuery --> nvENC NVidia driver not detected or driver is too old
WARNING> --> Error detecting NVidia Hardware Encoder Capabilites

Your driver isn’t reporting it’s CUDA capabilities. Try using one of the recommended NVIDIA drivers.

It’s using handbrake and a software encoder (handbrake is reporting no intel CUDA support) to encode it which is why it’s taking 1.5hrs

2018-02-23T20:28:39 MCEBuddy.AppWrapper.Handbrake --> [20:28:39] Intel Quick Sync Video support: no

2018-02-23T20:28:48 MCEBuddy.AppWrapper.Handbrake --> [20:28:48] + encoder: H.264 (libx264)

If you look at the File 1 log file you’ll see that it shows the Donator version of Comskip was used. It also shows the same in the File 2 log, which I’m now attaching as a zip file (Thank You for that tip!). After I created File 1 I downloaded the video graphics update directly from the Dell website, since my laptop is a Dell Latitude E6530 and as you’ll see in the File 2 log CUDA is detected.
File 2.zip (684.8 KB)

Thank You for pointing out key items to look for in the logs. I think I may have figured out what the issue is. When I created File 1 it was with MCEBuddy version 2.4.8, which has the Donator Comskip included and is why the Advertisement Scan was 36 minutes. At the time I created the file I did not realize Comskip was included with version 2.4.8. The things I was reading about 2.4.8 and what I found in the forums was confusing because it kept saying if you are converting H.264 files to use the Donator version of Comskip and so I thought I had to donate $10 to get the Donator version, but obviously it’s already in 2.4.8, which is confirmed in the log file for File 1.

Prior to converting File 2, I downloaded the Donator version of Comskip and unzipped it to C:\Comskip. I then changed the settings in MCEBuddy and pointed Comskip to this directory.
image

By doing that I’m wondering if MCEBuddy is somehow seeing two Comskips (if that makes sense?) thereby making the advertisement scan longer. What I’m going to try next is remove the setting in MCEBuddy, where I have it pointing to C:\Comskip, and leave it blank. I’ll convert another file and see if that makes a difference in the Advertisement scan. I’ll report my findings once I’ve completed the conversion.

I had a look at the two conversions and the sources files (while different) are very similar is similar in characteristics (size, duration, format, encoding, frame rate, bitrate, etc). So I’ll assume they are identical for purposes for comparison.

All other parameters also appear to be the same.

With the bundled Comskip I see a processing speed of about 100fps

2018-02-23T20:15:48 MCEBuddy.AppWrapper.Comskip --> 215069 frames decoded in 2188.00 seconds (98.29 fps)

Where as with the external Comskip I see a processing speed of about 40fps

2018-02-25T12:41:04 MCEBuddy.AppWrapper.Comskip --> 219470 frames decoded in 5417.97 seconds (40.51 fps)

What this is basically saying is that the bundled Comskip is about 250% faster than the external Comskip.

There would be a few reasons for this:

  1. The bundled comskip is a custom build and likely uses newer libraries which are faster to process video.
  2. The Comskip INI file being used, the bundled version by default uses the bundled in Comskip.ini where as the external Comskip used the comskip.ini in the external directory

If you want to rule out differences in Comskip.ini you copy/replace either INI so that both methods use the same INI and that will confirm if the bundled Comskip runs faster

I went into the settings for MCEBuddy and removed the C:\ComSkip\comskip.exe from the Comskip path. I then deleted C:\ComSkip just to make sure it was no longer detected. I converted another file, similar to the first two and still have the same result. It’s taking over an hour to do the advertisement scan and showed around 46fps for Comskip.

I decided to start over from scratch and uninstalled MCEBuddy version 2.4.8 and deleted any left over log, profile, etc files. I then reinstalled MCEBuddy, did not tweak any of the settings and converted the attached File. Although the conversion time was reduced to 22 min total between analyzing and converting, which is great, the advertisement scan took 1 hour 18 minutes and it showed Frames Decoded at 46.04fps. In the file you’ll see it shows the Donator version of Comskip. Since this was a reinstall of MCEBuddy this is the bundled Comskip. It also confirms CUDA is active and being used. I’m also including the Comskip.ini file for review, so you can see if anything within it needs to be tweaked. Again, I really appreciate your help with this. Thank YouFile 3.zip (565.7 KB)
comskip.ini (6.2 KB)

So I’m a little confused now, the first time the bundled comskip ran at 100fps and the donator version at 46fps. The second time the bundled comskip ran at 46fps?

If so then the only thing I can think of is that some other process in your computer is taking up the resources to be used by Comskip. You may want to check what other processes are running in the background.

Also try changing this value in your comskip.ini

hardware_decode=0

make it 1 to enable hardware decoding. It’s a hit or miss, by default its off since not systems support hardware decoding but if your does it may well boost it.

Also try to increase your MCEBuddy Process Priority to High from the main screen, bottom right corner.

I changed hardware_decode to 1 and increased the MCEBuddy Process Priority to High, but that didn’t help. The advertisement scan took a bit more than an hour. I went back and reviewed my original post, but can’t seem to figure out why on File 1 the Advertisement scan was 36 minutes and now it’s over an hour. File 1 was using the bundled Donator version of Comskip. The only thing I can think of is my recordings have somehow changed, but I don’t know how. I haven’t changed the setup of my Happague HD PVR 2 since I started using it. I remember reading somewhere that sometimes they change the broadcast signal and how commercials are identified within the broadcast, so maybe something changed between the time I recorded File 1 and File 2 and my subsequent recordings. I’ve read about users posting Comskip INI files for specific areas of the US, Cable Companies, etc. Maybe I’ll look and try some of those to see if they make a difference. Since my issue is with Comskip I’ll go to the forums there and see if anyone can figure out what’s causing the issue.

Thank You again for your help. It was very much appreciated. If I come across a solution I’ll post it here.