Noobie Question MP4 audio output 5.1

Using normal mp4 profile to convert WTV recorded with homerun prime to mp4. Does the mp4 container allow the for surround 5.1. MediaInfo shows the mp4 audio is set to 2 channel stereo. Can someone post an example of the audio changes that need to be made to the profile. Thank you…

Yes it does, check the Multichannel audio box in the conversion task options page:

The default is stereo audio since not all devices support multi channel audio (including some apple devices)

Thanks for the reply. I have had the multi channel audio selected however I have not check the select the best audio box. Do both need to be selected? I will give that a try.

Yes putting check marks in those two boxes caused the mp4 to save the audio as 5.1 plus. Thank you.

Now MediaInfo shows multiple channels. WMC or VLC will not output surround audio. When playing WTV files my receiver switches to Dolby Surround. When I play the new mp4 through WMC or VLC the receiver never switches to Dolby. I hope this is not beyond the scope of this forum. Thank you again for the assistance.

Attach your conversion log or look at the end of the file to see what audio track it’s reporting in the converted file.

Multi-way channel can be in different codecs. You can have AAC multi channel or AC3 (Dolby) multi channel. Depends on what your profile is using. The profile description tells you what will be created. You can always create a custom profile

Noobie alert. Where do I find the audio part of the log and where do I attach it? MediaInfo shows that is using AAC. I do know where the profile.config is located. Sorry for lack of knowledge.

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : mp4a-40-2
Duration : 45 min 52 s
Bit rate mode : Variable
Bit rate : 256 kb/s
Channel(s) : 2 channels
Channel(s)_Original : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 84.1 MiB (16%)

Check this out:

Here is the profile from the log.
–> Profile being used : MP4 Normal**
Profile entries ->
–> Description=Main profile, good quality 1 pass MP4 (H.264/AAC) conversion. Good for most conversions, produces good results and is faster than the two pass conversion.
–> 2pass=true
–> order=handbrake,ffmpeg,mencoder
–> mencoder-general=-ss 3 -vf pullup,softskip,yadif=0:-1,hqdn3d,harddup
–> mencoder-video=-ovc x264 -x264encopts bitrate=1400:me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=3:rc_lookahead=50:keyint=25:keyint_min=20:bframes=1:weight_b:level_idc=40:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=0:threads=auto
–> mencoder-audio=-oac faac -faacopts br=160:mpeg=4:tns:object=2
–> mencoder-audioac3=-oac faac -faacopts br=256:mpeg=4:tns:object=2
–> mencoder-ext=.avi
–> mencoder-remuxto=.mp4
–> mencoder-audiodelay=skip
–> ffmpeg-general=-threads 0
–> ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1400k -x264opts me=hex:trellis=1:subq=8:partitions=all:8x8dct=1:ref=3:rc-lookahead=50:keyint=25:min-keyint=20:bframes=1:weightb=1:level=4.0:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=0:threads=auto -map 0:v -sn
–> ffmpeg-audio=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
–> ffmpeg-audioac3=-acodec libfdk_aac -ab 256k -cutoff 18000 -map 0:a
–> ffmpeg-ext=.mp4
–> ffmpeg-audiodelay=skip
–> handbrake-general=–decomb --loose-anamorphic --verbose=2 -f mp4 -O
–> handbrake-video=–start-at duration:3 --preset Normal -q 18
–> me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=3:rc-lookahead=50:keyint=25:keyint-min=20:bframes=1:weight-b:level-idc=40:b-pyramid=normal:direct-pred=auto:mixed-refs:deblock=-1,-1:nofast-pskip:nodct-decimate:b-adapt=0:threads=auto
–> handbrake-audio=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
–> handbrake-audioac3=-E faac -R auto -B 256 -D 0 -a 1,2,3,4,5
–> handbrake-ext=.mp4
–> handbrake-audiodelay=skip

Ok I read the guide and have not idea what the next step would be in creating a line that would encode ac3 surround instead of using the AAC codec. Thank you.

Your profile is using the handbrake encoder, if that fails it falls back to ffmpeg and then to mencoder

Your handbrake profile audio is set to encode the audio to AAC, if you want it to use ac3 instead of aac then change faac to ffac3

and similarly for ffmpeg, it’s also using AAC audio

Change libfdk_aac to ac3

You can refer to the MKV profiles for samples if needed, they use AC3 audio instead of AAC audio.

It’s better to create a new profile with a new name than to change existing profiles.

Thank you so much for taking the time to explain how to make the settings. You have been very helpful.

1 Like