Custom AC3 Audio with MCEBuddy 2.4.7

Hello,

I recently upgraded from 2.4.6 to 2.4.7, and my profiles stopped working entirely. Checking the release notes, I saw that the profiles were completely changed in the new version, so I decided to start from scratch. Starting with the top default profile “MP4 High Quality” I wanted to make four changes:

-Keep the AC3 audio (no compression)
-Increase the bitrate from 1800 to 2400
-Skip Cropping
-Preserve Resolution

I’ve made the changes that worked perfectly in version 2.4.6, and with 2.4.7, I get files with no audio. Below is the text of my profile. I’ll see if I can attach the logs for a file, I’m not sure how this new forum works.

Thanks for any tips you can provide!
-guyinco6nito

[CUSTOM WTV]
Description=WARNING: Slow, main profile, high quality 2 pass MP4 (H.264/AAC) conversion. This can be helpful with low quality source videos but will not make much difference for HD or high quality source videos. Takes the most time but produces the best results.
2pass=true
order=handbrake,ffmpeg,mencoder
mencoder-general=-ss 3 -vf pullup,softskip,yadif=0:-1,hqdn3d,harddup
mencoder-video=-ovc x264 -x264encopts bitrate=2400:me=hex:trellis=2:subq=8:partitions=all:8x8dct:ref=5:rc_lookahead=50:keyint=25:keyint_min=20:bframes=3:weight_b:level_idc=40:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=2:threads=auto
mencoder-audio=-acodec copy
mencoder-audioac3=-acodec copy
mencoder-ext=.avi
mencoder-remuxto=.mp4
mencoder-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 2400k -x264opts me=hex:trellis=2:subq=8:partitions=all:8x8dct=1:ref=5:rc-lookahead=50:keyint=25:min-keyint=20:bframes=3:weightb=1:level=4.0:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=2:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec copy
ffmpeg-audioac3=-acodec copy
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=–decomb --denoise=“weak” --loose-anamorphic --verbose=2 -T -f mp4 -O
handbrake-video=–start-at duration:3 -e x264 -b 2400 -x me=hex:trellis=2:subq=8:partitions=all:8x8dct:ref=5:rc-lookahead=50:keyint=25:keyint-min=20:bframes=3:weight-b:level-idc=40:b-pyramid=normal:direct-pred=auto:mixed-refs:deblock=-1,-1:nofast-pskip:nodct-decimate:b-adapt=2:threads=auto
handbrake-audio=-acodec copy
handbrake-audioac3=-acodec copy
handbrake-ext=.mp4
handbrake-audiodelay=skip
SkipCropping=true
FixedResolution=true

-acodec is used by ffmpeg. Handbrake uses -E so it should look like:

handbrake-audio=-E copy -a 1,2,3,4,5
handbrake-audioac3=-E copy -a 1,2,3,4,5

The -a 1,2,3,4,5 tells it to keep the first 5 audio tracks

Similarly mencoder uses -oac and not -acodec

To skip cropping check the Disable cropping option in the Conversion Task -> Expert Settings page

To increase the bitrate you can move the quality slider in the Conversion task page to 33% (33% increase over 1800).

To preserve the resolution, move the Max resolution slider all the way to the right in the Conversion task settings.

This way you minimize modifications to profiles.

That works, thanks much!
-guyinco6nito

1 Like