H265 MKV Files Significantly Larger than MPEG2 Source

With the most recent update to MCEBuddy, my file conversions have gone up in size significantly. A MPEG2 recording from Plex that is getting converted to H265 MKV would go from a 5.5GB file to 48GB for the resulting MKV. Even when re-encoding it, in some cases the file would still be larger at 6-7 GB. I haven’t adjusted any settings and was using a guide from 2016 when I setup MCEBuddy and Plex. I think I have determined the issue is with the quality setting. Prior to the update, this was left at 100% and file sizes were typically smaller, a 6GB TS file would drop to 1.5 GB.

Doing some testing with a 5.5GB recording of SNL, if the quality setting is set to 0, the resulting size is smaller (3.5 GB), with no quality loss that I can tell. Should I drop to the negative end on the quality scale to further reduce the file size? I’d like to try and get back to the 1.5GB or lower size I used to get.

I am running W10 with MCEBuddy 2.5.2, Handbrake 1.3.0, and using a Nvidia P2000 on 441.66 for HW acceleration.
Saturday Night Live (1975) - S45E10 - Eddie Murphy.ts-Com Removal-2019-12-22T17-53-52.1929136-05-00.log (2.2 MB)

According to your log, you’ve set your quality multiplier to +20% and consequently your file size is increasing accordingly from about 5GB to 6GB.

2019-12-22T18:24:00 MCEBuddy.Transcode.ConvertWithHandbrake --> Original file size [KB] 5,221,935.00
2019-12-22T18:24:00 MCEBuddy.Transcode.ConvertWithHandbrake --> Finished video conversion, file size [KB] 6,333,503.00

Also your bitrate was originally 8mbps and your converted file bitrate is very high at 9mbps. It should ideally bring it down by 5-8 times (which will result in a smaller file). Try using the default quality settings.

Thanks. Do you know when the quality slider changed functionality? Before I could leave it at 100% and I never got file sizes this large. I only saw this when I moved to 2.5.1 and later. I’ll leave everything at 0% for now but these files are still larger than what I was seeing 2-3 months ago.

It could be related to a profile setting or handbrake. Try this, open your profiles.conf, locate your profile and from the ffmpeg-video line remove the -preset medium and then save it.

Test it with this change and see how it responds.

Did you use a custom version of handbrake or what ships with MCEBuddy?

I used the version of Handbrake that shipped with MCEBuddy. Removing the -preset medium dropped the file size to what I was seeing before. Quality appears to about the same.
NCIS (2003) - S17E10 - The North Pole.ts-Com Removal-2019-12-27T20-32-37.2969273-05-00.log (1.6 MB)

Fyi, I experienced a similar problem on an update where my h265 mp4 files became larger than the original files after an update. I never really figured out what the issue was as none of my settings changed. I also was using handbrake that comes with mcebuddy. In my case, I was using hardware acceleration on my Playon recordings, then also using hardware accelerating for mcebuddy. Somehow the update didn’t handle this well, but when I turned off the Playon hardware acceleration, the mcebuddy output files went back to their previous small size (in my case about 10% of the original file size). The mcebuddy process is slower than before the update for some reason, but at least I’m getting the result i was before. I do still have mcebuddy hardware acceleration on.

Check your quality slider settings, if it’s > 0% it’ll be larger. Also if you attach your conversion log we can see what’s going on.