Dot Net update kills nvidia cuda function

The recent windows dot net update(KB4457035) on my windows 7 machine killed my nvidia graphic card’s encoding function on mce buddy (2.4 R8)

I have a GeForce GTX 650 Ti BOOST and the logs correctly indicate as much. They also indicate MCE Buddy is using CUDA encoding function.

But transcodes are using 100 percent of cpu and taking over two hours (in some cases 5 hours) to complete.

This was something I experience when I did not have the newest nvidia graphic driver installed.
I decided to uninstall KB4457035 and my video conversions went from almost 2 hours on a hour program to 25 minutes. CPU usage dropped from 100% to 45-60%.

Is this an nvidia fix or a dot net fix or a mcebuddy fix?

Either a NVIDIA driver or windows system fix. Hardware encoding is done by the driver which runs as a system service. Not sure which one broke with the service patch. Not likely a .NET issue since .NET doesn’t really deal with system drivers etc.

Did you driver version change with the patch?

Edit: the net KB patch description shows that some patches were made to the graphics subsystem in this patch so it’s possible it broke it.

Have you tried running MCEBuddy as a command line engine from your user login? If not try it. Windows 7 has very limited support for hardware encoding as a system service. This feature was fully matured in windows 8.1.

I’ll take a look at using mcebuddy command line engine. I’m sure I’ll have to use the user guide to figure this out.

But saying it does work, what is the fix? Run mcebuddy without the gui? I’d rather skip the update.

You can start the Command Line Engine from the Start Menu, the only difference is that the core “engine” runs as a user program instead of a system service. What this means is that the user needs to be logged in at all times with the engine running (you can set this to start automatically at user login using a scheduled task in windows) for the conversion to work. It has no impact on the GUI.

Did the common line engine from the Start Menu work for you or was uninstalling the .NET update the only solution?

Sorry for the long wait for a response.

I did uninstall the dot net update and that did the trick for a while.

Now, the problem seems to have cropped back up again. Not sure if windows did an update behind my back or what.

Decided to do a windows update just to be safe and then use the command line option as you stated. Will report back with any news.

Ok. Tried it with command line function and still no go.

CPU is back to 90% and transcodes for a one hour program is back to 2 hours or more.

Not sure what the issue is.

Windows may be broken/corrupted. Best solution is a fresh install.

Better solution?

Update nVidia drivers.

Took the better solutions.

Things are back to normal as of this morning.