Did i buy the wrong card? No NVENC capable devices

I’m using a gtx 1650 and well… been trying to get it working again. It was working good back like 3 months ago back in September with 5/9/2019 MCEBuddy Build Version 2.5.1 would love to keep it as it was the fastest version of mcebuudy even with the new ones it was about 2 times as fast (was for me, don’t know why). I’m now getting WARNINGS and ERRORS but with converting times of about 6 mins with the new mcebuddy 2.5.3 24/12/2019 vs about 2mins with 2.5.1 5/9/2019… sorry i don’t have the logs from back then only new ones. i tried to recreating everthing from back then from the same drivers to using DDU over and over again to trying to different ffmpeg to playing with different profiles
this is the only thing i still have from back in September i believe it was using about 70% of the cpu

Bob’s Burgers - 3x18 - It Snakes a Village.mkv-mp4 fast-2019-12-30T21-55-22.5802682-06-00.log

2.5.3 24/12/2019 about 70% cpu (501.1 KB) slow|369x500

Your logs shown that MCEBuddy is detecting your nvenc encoder, however ffmpeg is unable to use it:

2019-12-30T21:56:20 MCEBuddy.AppWrapper.FFmpeg --> [h264_nvenc @ 00000000028e5d40] No NVENC capable devices found

However handbrake is able to use it with a decent conversion speed of about 98fps.

Sounds like your graphics driver may have changed and is causing ffmpeg some grief. Try changing your driver to a more stable version or rolling it back.

As for GPU utilization see this topic for more details.

i need some help on converting videos from high 10 down to 8 bit
this is what i’m using
[MP4 Fast]
Description=Fast MP4 (H.264/AAC)
order=ffmpeg,handbrake
ffmpeg-general=-threads 0 -hwaccel auto
ffmpeg-video=-ss 0 -vcodec libx264 -b 1000k -x264opts cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec aac -ab 128k -map 0:a
ffmpeg-audioac3=-acodec aac -ab 160k -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=–loose-anamorphic --verbose=2 -f mp4 -O
handbrake-video=–start-at duration:0 -e x264 -b 1000 -x cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto
handbrake-audio=-E faac -R auto -B 128 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
AutoDeinterlace=false

Plex is currently having to transcode everything with high 10

This kind of stuff is above my paygrade any help will be much appreciated

Doesn’t Plex transcode based on the capability of the playback device? Maybe start with figuring out what format is supported in the playback device and then pick a profile to match.

how do i get my videos from high 10 down to 8 bit? ffmpeg-video=-ss 0 -vcodec libx264 -b 1000k -x264opts cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto -map 0:v -sn
i don’t know what any of this means

I’m not familiar with the ffmpeg options, but they’re documented on the ffmpeg.org site.
If you were using Handbrake, there are separate encoders for 10 and 12 bit. e.g. “x264” is the 8-bit encoder, and “x264_10bit” is the 10-bit encoder. So from the options in your profile, you can tell if you’re downconverting to 8-bit.

I wouldn’t be surprised if the ffmpeg encoder options are similarly selected. If you are wanting to be sure, configure the transcoding engine priority to use Handbrake with the 8-bit encoder in the profile and don’t use FFMPEG.

Looked at the FFMPEG site and the reference is here:

9.10.1 Supported Pixel Formats

x264 supports 8- to 10-bit color spaces. The exact bit depth is controlled at x264’s configure time. FFmpeg only supports one bit depth in one particular build. In other words, it is not possible to build one FFmpeg with multiple versions of x264 with different bit depths.

So the real answer is who/where did you get your libx264 codec library from and what options did they configure when it was compiled.

Dollars to donuts, everyone is compiling the libx264 with an 8-bit colorspace. You would need to have the same colorspace support in the playback program/device - e.g. VLC, Plex, etc.

Goose can likely answer how the libx264 was built for FFMPEG, and the MCEBuddy FFMPEG just says the default/provided libx264 was used.