Copy source to local temp folder when not remuxing

My files are on a NAS (Unraid). I’m not remuxing (no commercial removal needed). If i was, mcebuddy would create a .ts file on my local temp folder and work the file from that folder. Since i’m not remuxing - mcebuddy works the file from Unraid directly over the network, constantly maintaining a connection. Unfortunately, Unraid tends to bog down/choke up the drive array during heavy/sustained writes (like when the cache drive gets flushed). During these slowdowns on the server all hell breaks loose with my conversions. At best they hang for a while and complete, or just error out. At worst, they show no errors (marked as completed) but produce a chopped off file (half the show, etc).

Is there a way to copy the source from the NAS to mcebuddytemp prior to the conversion, and have mcebuddy work that file?

MCEBuddy copies ALL files to the temp folder and only works on the temp folder (never on the original unless you’ve told it not to). Make sure you haven’t checked these options on your Conversion Task -> Expert Settings

  • Skip remuxing files
  • Skip copying original files

Both are unchecked.

Only the new file mcebuddy is creating is in temp, the source never moves from the NAS.

Sorry, Skip remuxing is checked, skip copying is not.


Tried “Skip copying original files” both checked and unchecked and observed the same behavior - source stays on lan (no copy made to temp), -converted file is created in temp. In other words, not sure if it does anything.

MCEBuddy always copies the original file to the temp folder as Goose pointed out above, check your logs and you’ll see it.

I wish that was the case.

Not sure what to look for in the logs to properly check why this is happening.

Try attaching them here and we can look into it. Assuming you’ve unchecked both options, it does give a warning if you try to enable them.

Another Period - S03E02 - WEBDL-1080p.mkv-tvtester2-2019-11-13T09-41-29.8993119-05-00.log (1.2 MB)

BOTH Skip options should not be checked:

Skip Copying Original File for Backup -> False
Skip Remuxing Original File to TS -> True

You’ve enabled the Skip remuxing option so it won’t make a local copy of it in the temp folder. MCEBuddy by default remuxes the original into a TS file in the temp folder (or copies it if the original is a TS file) and then works on the temp folder. So uncheck that option and it will no longer work on the original file after remuxing it to the temp folder.

I may be misreading the log, but my settings do not have both boxes checked. Skip remuxing is checked, skip copying is not.

Skip Copying Original File for Backup -> False
Skip Remuxing Original File to TS -> True

I understand how mcebuddy works when the file is remuxed. The problem is that remux occasionally butchers my files. This problem doesn’t occur when i convert directly from the mkv.

The goal here, as the title of the thread says is - copy file to local temp folder when NOT remuxing… Is that possible ?

Remuxing is a form of copying, just’s just changing the container format so something that’s more malleable, not altering any video properties/content. It’s redundant to copy of you’re remuxing, so why do you want to limit the remuxing? Just leave remuxing on and it’ll make a local copy.

Remuxing can butcher a conversion, and is just an unnecessary step if you’re not skipping commercials.

It works fine most of the time, but it has it’s issues. Occasionally it sets the wrong framerate, or colorspace. At one point i noticed some of my conversions were skipping frames. Looked at the metadata and the framerate was something like 29.6 instead of normal 29.97 etc. Adding --cfr or turning off remuxing fixed the problem, so no big deal… I missed it in my testing, so went ahead with a long batch and had to redo like two weeks worth of conversions. I still had the source, so again - no big deal, but very annoying.

The biggest problem with remux is subtitles. By default, the scodec is ignored in the remuxer so the only way to get subs is by triggering ccextractor, which itself works fine most of the time, but has its issues. There is currently no good/easy way to work PGS subtitles, which are becoming more and more common on blurays etc. PGS are better off passed, not worked, and remux doesn’t offer a way to pass them while ccextractor doesn’t offer a way to extract them - so basically no PGS with remux.

I actually tried to remedy this yesterday by butchering the config file and changing the default
CopyRemux0=-i -ss 0 -vcodec copy -acodec copy -map 0:a -map 0:v -f mpegts
CopyRemux0=-i -ss 0 -vcodec copy -acodec copy -scodec copy -map 0:a -map 0:v -map 0:s -f mpegts

This helped a bit, but apparently mpegts has it’s own limitations on what kind of subs it likes and doesn’t like, so it didn’t work on all my files (no subs were passed to about 4 out of 12). So i tried this
CopyRemux0=-i -ss 0 -vcodec copy -acodec copy -scodec copy -map 0:a -map 0:v -map 0:s -f matroska
This was almost a success. Out of my 12 test files, 11 converted just fine with all the proper subs etc. The one that failed thew up an error about incorrect input color space. I am sure if i do some digging around i can find the params i need to fix this, but at some point you have to ask… why ?

When not skipping commercials, the only real advantage i see in the remux is the fact that it gives me a local file to work. Outside of that it’s just not needed. It can create wacky errors (frame rate), it requires a use of a third party app for subs (ccextractor), and doesn’t allow PGS at all. And overall, i just don’t see a point. My source is mkv, and so is my output, there is just no need to go through an intermideary format (ts). My handbrake profile passes subs without issues, never messes up framerate or worries about colorspace when working the mkv, so why bother ? I mean, i’m sure it makes sense in a whole lot of situations, but in mine - i would rather just copy the source, and work the source mkv off the local temp.

Thanks for your feedback. It makes sense that it should always make a local copy unless asked not to. If it’s remuxing then that’s a local copy, if it’s skipping remuxing it should make a local copy unless the skip copying option is selected.

This fix should be there in the next 2.5.2 beta build.

Thank you.

This is exactly what i was looking for. Very happy to see it addressed so quickly.