Comskip not detecting commercials

But system wasnt shut down or mcebuddy

Just want to know

If I open up a folder with already recordered mp4 files that has commercials then run it thru mcebuddy is it suppose to take commercials out or does mcebuddy

Only takes out while the source is live


It works for any file and depends on how you have configured your setup. Once processed files aren’t reprocessed unless you configure MCEBuddy to do so in the Monitor Location → Expert Settings (to avoid endless loops)

How commercials are detected and removed are based on your Comskip configuration. See this topic for more details:

Complicated for me, but i went to site as you said, copied the verizon ini and pasted it over the original ini, tried it and no luck same thing. With the setup of plex i have no problem, but when i record the series season 1-3 onto a usb and then transfer to hard drive and point MCEBuddy, no luck no matter what i try. MCEBuddy runs but when i check commercials still there.

We will need Logs to see what’s going on. Your last log showed that the conversion was terminated prematurely so it didn’t even complete. Check some other logs. You can also click on the History link on the main GUI page which will tell you the status. Locate a conversion that converted successfully and then attach the log for that conversion and I can tell you what’s going on with commercial detection.

sure and thanks again, i can let you remotely in via teamviewer if you can see and fix for me the latest logs says it exceeds 6000 so how can i send to you?

77 Sunset Strip - 2x07 - The Treehouse Caper.mp4-no com 77 sunset-2019-02-21T15-35-29.8076960-05-00.log (486.5 KB)

can anyone else please help. Is there a customer number that i can call directly for this. Thanks

The problem lies with your setup, 2 issues I’ve found so far:

  1. You’ve configured MCEBuddy to use some unknown version of Comskip in C:\Comskip. Any reason you aren’t using the default Comskip that ships with MCEBuddy?
  2. You’ve set your temp folder to an F drive. That’s your issue. Your custom Comskip can’t access it so it isn’t running.

MCEBuddy.AppWrapper.Comskip –> ComSkip: invalid option “–output=F:\ConverXtoDVD Drop\working0”

Start by using the default MCEBuddy settings (Comskip and temp folder) it should work fine

Thaks Goose, i will uninstall and setup again and send you the hist. I really appreciate the help.

ok i uninstalled correctly, clean uninstall, but same.
Here is the logV1221_20190115_100348.mp4-Convert to MP4-2019-02-24T08-33-19.8841819-05-00.log (509.9 KB)

i just switched to shadowalayzer see if that works, will let you know.

shadowanalyzer didnt work also, please help.

Your logs show that it found the commercials and removed them:

2019-02-24T08:36:20 MCEBuddy.AppWrapper.Comskip → Commercials were found.
→ Process exited with code 1
2019-02-24T08:36:23 MCEBuddy.CommercialScan.Scanner → Commercial Scan: Percentage Complete 98
INFORMATION> 2019-02-24T08:36:23 MCEBuddy.CommercialScan.Scanner → Skipping EDLP, using EDL file for commercial removal
2019-02-24T08:36:23 MCEBuddy.CommercialScan.Scanner → Testing EDL File Validity
2019-02-24T08:36:23 MCEBuddy.CommercialScan.Scanner → ParseEDL: Cut Segment Start:511.230 End:541.870 Action:0
→ ConvertCutListToKeepList: Keep segment Start:0.000 Stop:511.230
→ ConvertCutListToKeepList: Keep end segment Start:541.870 Stop:933.217
→ ConvertKeepListToCutList: Skip segment, too small Start:0.000 Stop:0.000
→ ConvertKeepListToCutList: Cut segment Start:511.230 Stop:541.870
→ ConvertKeepListToCutList: Skip end segment, too small Start:933.217 Stop:933.217
→ ConvertKeepListToCutList Done

Comskip only found one commercial which was cut by MCEBuddy.

If you think Comskip is not being aggressive enough to find commercials you can use the Comskip INI tool included to tune it to be more aggressive or use one of the ready made Comskip INI files described here:

but when i go thru them i see so much commercials, and before this i had read and installed verizon ini and no luck. This is so complicated.

Which is why there are tools provided to adjust the commercial detection to your needs. Did you you check out the link and use the Comskip Ini Editor tool provided with MCEBuddy?

Yes, i had added verizon ini, but still the same. I appreciate your help so much, thanks, but it gets frustrating when you can’t get it to work. Its hard to do it, can you log into my pc via teamviewer, i will allow you. Of course, if you have time.

i registered and asked in verizon forum ini if someone can create an ini for me. Thanks again buddy, i owe you. And again let me know if you want to log into my pc, Thanks

i posted a reply to their forum cause it did not work. Back to square one.

yep no help, but thanks again for trying. I really was hoping i can get it too work.

Hey, I also have verizon fios, here is my ini file, it works pretty well to remove commercials and the beginning of the next show, for the most part. Give this a try and let me know. Im working on trying to get it to remove the ending of the previous show since I have set plex to dvr 1 min. before and after the show time

comskip.ini (6.2 KB)