[BUG] No chapter marks after processing - special characters

I’m running 2.5 using comskip/ffmpeg for processing shows. I used to use MCEbuddy with windows 7 machine without issue.

I am now using Windows 10 vm.

For some reason, after processing, I am not getting any chapter marks. Not sure why. Everything appears to be running normal.

Attached are a few logs.

Any thoughts?

All In With Chris Hayes - S01E1915 - #1915 All In With Chris Hayes.ts-Convert to MP4-2020-07-02T21-01-58.log (2.8 MB) CNN Tonight with Don Lemon - S01E2167 - #2167 CNN Tonight with Don Lemon.ts-Convert to MP4-2020-07-03T04-01-41.log (2.6 MB)Cuomo Prime Time - S01E618 - #618 Cuomo Prime Time.ts-Convert to MP4-2020-07-02T03-01-26.log (2.7 MB)

Something is blocking mcebuddy from accessing the Comskip generated EDL file. Possibly an antivirus or something background software:

MCEBuddy.AppWrapper.Comskip --> 110688 frames decoded in 491.35 seconds (225.27 fps)
2020-07-02T21:14:07 MCEBuddy.AppWrapper.Comskip --> The commandline used was:
2020-07-02T21:14:07 MCEBuddy.AppWrapper.Comskip --> D:\MCEBuddy2x\comskip\comskip.exe --ini=D:\MCEBuddy2x\comskip\comskip.ini --output=D:\MCEBuddy2x\tmp\working0 “D:\MCEBuddy2x\tmp\working0\All In With Chris Hayes - S01E1915 - #1915 All In With Chris Hayes.ts”
2020-07-02T21:14:07 MCEBuddy.AppWrapper.Comskip --> Setting ini file to D:\MCEBuddy2x\comskip\comskip.ini as per commandline
2020-07-02T21:14:07 MCEBuddy.AppWrapper.Comskip --> Using D:\MCEBuddy2x\comskip\comskip.ini for initiation values.
2020-07-02T21:14:07 MCEBuddy.AppWrapper.Comskip --> Commercials were found.
–> Process exited with code 1
2020-07-02T21:14:09 MCEBuddy.CommercialScan.Scanner --> Commercial Scan: Percentage Complete 99
INFORMATION> 2020-07-02T21:14:09 MCEBuddy.CommercialScan.Scanner --> Skipping EDLP, using EDL file for commercial removal
WARNING> 2020-07-02T21:14:09 MCEBuddy.CommercialScan.Scanner --> Cannot find or access EDL File

Thanks for the response Goose.
Took a look at the comskip.ini and discovered it was not set to produce an edl so I implemented that.

Now a new issue popped up, attached is the log. This is the part that interests me.

Chapter File : D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.chap
Target File : D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.mp4
2020-07-04T13:01:55 MCEBuddy.AppWrapper.MP4Box --> Launching process D:\MCEBuddy2x\mp4Box\mp4box.exe
2020-07-04T13:01:55 MCEBuddy.AppWrapper.MP4Box --> Process arguments  -chap "D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.chap" -add "D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.ttxt":chap "D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.mp4"
2020-07-04T13:01:55 MCEBuddy.AppWrapper.MP4Box --> UI Session Admin Process : False
2020-07-04T13:01:56 MCEBuddy.AppWrapper.MP4Box --> Setting process priority to Normal
2020-07-04T13:01:56 MCEBuddy.AppWrapper.MP4Box --> Setting CPU affinity to -> 15
2020-07-04T13:01:57 MCEBuddy.AppWrapper.MP4Box --> [Importer] Unknown input file type for "D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - "
2020-07-04T13:01:57 MCEBuddy.AppWrapper.MP4Box --> Error importing D:\MCEBuddy2x\tmp\working0\AM Joy - S01E401 - #401 AM Joy.ttxt:chap: Requested URL is not valid or cannot be found
--> Process exited with code 1
ERROR> --> Mp4Box adding subtitles failed
ERROR> 2020-07-04T13:01:59 MCEBuddy.Engine.ConversionJob --> Adding subtitles and chapters failed

Not sure what is going on here. AM Joy - S01E401 - #401 AM Joy.ts-Convert to MP4-2020-07-04T12-22-26.log (821.3 KB)

The special character # in your filename which is causing MP4Box to fail. This has been fixed in today’s 2.5.5 BETA build.

Installing the beta as I type. Will report back with what I find.

This worked for me. Thanks Goose.

One quick note. I think this beta version is causing my windows 10 machine to freeze intermittently. Perhaps has something to do with Firefox or my browser running at the same time?