Audio Sync Problem - Starting about the middle of October?

I don’t even have a theory on this one. The audio sync of all recordings is off starting about the 11th of October based upon converted files.

I updated TabloRipper to Version: 2.3.4 on November 1, 2017.

All of my tests today use same file: America’s Test Kitchen - s17e11 - Big Easy Favorites - ch4.1.mp4 but all files used with MCEBuddy are affected. Ch4.1 is a PBS station recording which does not have any commercials.

The original concept was to have MCEBuddy trim 60 seconds from the front of the file and 2 minutes from the end of the file. The file start and stop cuts have been removed (set to 0 and unchecked) for these tests.

  1. On my Tablo the file plays fine to a television.
  2. I am using Tablo Ripper to pull the file down to my PC. The downloaded file plays fine.
  3. The MCEBuddy conversion moves the file and the audio sync issue shows up then.

I am including images of my configuration and two log files created in the Debug mode.

Audio Sync 1

mcebuddy.log (1.6 MB)

America’s Test Kitchen - s17e11 - Big Easy Favorites - ch4.1.mp4-PBS Trimmer-2017-11-02T13-23-25.6723657-04-00.log (355.1 KB)

Like I said, I don’t even have a clue what is going on.

It may have something to do with this:

2017-11-02T13:24:51 MCEBuddy.AppWrapper.FFmpeg --> [mp4 @ 00000000003bda20] Malformed AAC bitstream detected: use the audio bitstream filter ‘aac_adtstoasc’ to fix it (’-bsf:a aac_adtstoasc’ option with ffmpeg)
2017-11-02T13:24:51 MCEBuddy.AppWrapper.FFmpeg --> av_interleaved_write_frame(): Operation not permitted

Possibly the format of your file has changed throwing ffmpeg off.

We’ve got a new build of ffmpeg coming out with today’s BETA build which may handle such audio anomalies better. Try out tonights 2.4.8 BETA build.

If you have a small sample 100-200MB upload it to our server so we can add it to our test suite.

I set up FileZilla exactly as the JPG showed.

I can log in but FileZilla says:

“Connection Timed out after 30 Seconds of inactivity”

“Failed to retrieve directory listing”

Perhaps the ftp server is on break?

CraigM

Okay got it, thanks for reporting it. Fixed it up, it should be working now. The AWS IP had changed and we needed to resync the settings.

I just put two half hour shows on the ftp server for testing. One is out of sync, the other is the original file downloaded from my Tablo. This is a cooking show so there is a lot of time where the hosts are speaking. This file should be good for testing the audio sync problem.

Please delete them and the directory when you are done with them.

Thanks, CraigM

There appears to be something wrong with this file:

America’s Test Kitchen - s17e11 - Big Easy Favorites - ch4.1.mp4

I can’t open it in any player, MediaInfo and FFMpeg can’t read it either at all. It doesn’t appear to be a valid video file.

I uploaded another copy of the file.

CraigM

I am using the 2.4.8 Beta dated Nov 2. The audio sync is still way off. The beta really has not made a difference.

I am sorry to report that I am not using MCEBuddy until we can get this resolved. How can I help?

CraigM

So I tested your sample file America's Test Kitchen - s17e11 - Big Easy Favorites - ch4.1 and using the latest 2.4.8 BETA build of MCEBuddy with the MP4 Normal profile and Comskip for commercial removal and it worked perfectly! No issues, the sound is perfectly in sync all the way through.

Try the latest 2.4.8 BETA. If you’re facing an issue, upload the original video and the conversion log file.

Goose,

Yes, I agree using the MP4 Normal profile the audio is in sync. So the problem is with the MP4 Unprocessed profile.

I love your enthusiasm but America’s Test Kitchen is a PBS show and does not have any commercials in it. So I use the MP4 Unprocessed profile with no Ad remover to save time on the conversion of all PBS shows.

I just downloaded and installed 2.4.8 Beta because the date on the directory had changed….it appears that the files in the zip file did not change, but I installed it anyway.

Using the MP4 Unprocessed profile, trimming 60 seconds from the beginning and end, there is a very noticeable audio sync delay.

Running the MP4 Normal profile takes about 40 minutes longer on the half hour show. Running on an Intel I7 with tons of memory is a lot like watching paint dry.

Yes, I agree using the MP4 Normal profile the audio is in sync. So the problem is with the MP4 Unprocessed profile.

Keep up the great work! How do I help tune the MP4 Unprocessed profile?

CraigM

Will check it out, no known issue at all. Need to figure out why ffmpeg is choking if there’s no ad removal. With ad removal there could be a host of reasons but without it should be straight forward.

So I’m able to replicate the issue, something about that video is choking up ffmpeg while trying to copy the video and audio. I’ve tried using a very old versions of ffmpeg just incase the new ones had an issue but same deal. It’s something about the video which isn’t complying with the “standard” is throwing ffmpeg. I’ll continue to experiment and see if I can nail what’s the issue and then find a solution for it. Thanks for the sample.

Meanwhile check if you upgraded your tv tuner drivers. What do you think changed in Oct?