Audio out of sync

Request Type:
BUG / NEW FEATURE
Audio Out of sync

MCEBuddy Version and Type (32bit or 64bit):
64 bit

Operating System and Type (32bit or 64bit):
Windows 7 64

Summary of the problem or suggestion:
I am converting video recorded using PlayOn. Original file is fine. Comskip with markers, select best sound track unchecked, Cut 3 seconds off beginning cut 8 seconds off end, MP4 Fast (audio ever so slightly off), MP4 Normal (bad), Ucompressed (worst). I’m using a windows 7 PC my work was getting rid of to use as a plex server and video recorder. Everything works great but the one thing I thought would work best was MCEBuddy and this is the thing that isn’t working properly. I’m not a coder. Can someone help? I’ve tried reinstalling but no luck. Found other forum post about this topic but no help.

Steps to replicate the bug:

Screenshots:


Better Call Saul - s01e02 Mijo.mp4-Convert to MP4-2019-07-08T07-11-29.7098650-05-00.log (513.1 KB)

I dont’ see any obvious errors in your video recording but do I see that there’s an sync delay between your video and audio streams defined in the container:

2019-07-08T07:13:39 MCEBuddy.VideoProperties.VideoInfo --> Audio Delay : -1.008

Since your profile has disabled delay correction, MCEBuddy doesn’t do anything:

–> ffmpeg-audiodelay=skip

2019-07-08T07:13:48 MCEBuddy.Transcode.ConvertWithFfmpeg --> Skip Audio Delay : skip

You can try to set the ffmpeg-audiodelay parameter to auto in your profile (see the advanced commands) OR you can correct the sync yourself but setting the audio correction offset in the Conversion Task -> Expert Settings page

<encoder>-AudioDelay=xxx/auto/skip (v2.1.2-2.2.18, 2.2.19+)

This parameter is set for each encoder type, e.g. ffmpeg, mencoder or handbrake

When xxx is set to skip then it tells MCEBuddy to skip auto correction of audio delay (sync). This is useful for some file formats such as AVI where audio gets skewed on auto correction.

If this parameter is set to a numerical value, then this parameter is used to manually specify the audio delay correction to correct audio sync, xxx is a +ve or a -ve number in seconds.
A value of 0 means that MCEBuddy will skip any delay correction.

If the value is equal to auto , it adds or subtracts the delay specified to the auto calculated audio delay for the video.

By default this this parameter is set to skip .

E.g. mencoder-AudioDelay=0.85

Thank you for the response. I didn’t notice the audio delay option. However I would like to know how to do the auto delay correction but again I’m not a programmer and I wouldn’t even know how to get to the code line in order the change it. would you be able to give me a quick walkthrough on how to do it? I mostly want this in case I want to change settings without having to figure out exactly how much delay there is every time. Thank you again so much

It’s quite straightforward. Open the MCEBuddy installation directory, in there open the config folder and then open the file profiles.conf

Find the section for the profile you’re using (e.g. MP4 Unprocessed) and change
ffmpeg-audiodelay=skip
to
ffmpeg-audiodelay=auto

If that line doesn’t exist, then add it.

I was able to find and change but it didn’t work. Thanks you ever so much for your help and I will just change it manually.