Subtitles out of sync - how to do this workaround?


#1

I am recording from an HDHomeRun Prime with Cablecard using Windows Media Center. I am using the paid for comskip for commercial detection (seems to work just about spot on). However, the subtitle file is pretty much always out of sync. I have played with the subtitle offset settings many times, thought I got it right with a test file, but subsequent recordings are not correct. Its like the offset needs to be different for each recording.

So, my thought is to do the following:

  1. Identify commercial segments
  2. Convert full length video into MP4 while burning subtitles
  3. Cut MP4 commercials out

This should result in having the subtitles burned in before cutting the video, so they should not be out of sync ever. Thoughts? How would I set it up to make this happen?

Thanks.


#2

Is this possible?


(Goose) #4

Subtitles can be tricky due to the nature of MPEG recordings.

See this post on adjusting Subtitles sync:

Identify the type of sync issue you’re facing, is it progressive or constant and you can then adjust the settings accordingly.

What you want to do can also be done. See the advanced commands sections on how to delay cutting advertisements to AFTER the conversion, set PreConversionCommercialRemover=false

You may also want to refer to the UniversalCommercialRemover setting as appropriate.

As for burning the subtitles into the video use the SubtitleBurn=true command in your profile


#5

I have tried those techniques… what works for one recording, doesn’t work for the next. Hence I am hoping to use the built in ability to run commands at the very beginning to do what I want. Its a matter of what command do I need to run to make this happen. I am familiar with all you referenced.


(Goose) #6

Not sure what you’re saying. If you’ve implemented what you wanted to do then where’s the issue? If the subtitles are burned into the video before being cut, what’s the problem?


#7

Sorry, to clarify, I haven’t figured out how to burn the subtitles before doing the commercial detection / cutting.


(Goose) #8

As I had mentioned set PreConversionCommercialRemover=false and SubtitleBurn=true in your profile.