Set-up causing Never-ending conversion loop of original recordings?

I have a Never-ending conversion loop of original recording, and am looking for some help.

I apologize in advance if this was already answered, I did not see it if so.
I may have a simple set-up blunder, but I am looking for assistance in keeping MCEBuddy from looping conversions. (I woke to 22,000 log files :slight_smile:

My initial thought is, can I not have Monitor Path be the same as the conversion destination?:

Search Path -> D:\recordings
Destination Path -> d:\recordings

Background on this, it is the path I have Plex recordings write into.

My second thought was in reading a prior post, the indication was I needed a trailing “” after the path, but even when I add that “”, it does not “save”, it gets removed.

MONITOR TASK OPTIONS ==>
Task -> d-recordings
Search Path -> D:\recordings
Search Pattern -> .dvr-ms;.wtv;.asf;.avi;.divx;.dv;.flv;.gxf;.m1v;.m2v;.m2ts;.m4v;.mkv;.mov;.mp2;.mp4;.mpeg;.mpeg1;.mpeg2;.mpeg4;.mpg;.mts;.mxf;.ogm;.ts;.vob;.wmv;.tp;*.tivo
Search Path Exclude ->
Monitor Delete Original -> True
Monitor Archive Original -> False
Monitor Archive Folder ->
Monitor SubDirectories -> True
Monitor Converted Files -> False
ReMonitor Recorded Files -> False
Minimum Age -> 15

====

Profile -> MKV High Quality
Source File ->
Relative Source Path ->
Destination Path -> d:\recordings
Working Path -> C:\temp
Fallback Destination -> False
Skip ReProcessing -> True
Check Reprocessing History -> True

Can you attach the mcebuddy.log file, I can’t see all the settings here. Likely you’ve checked on of the “red” settings which remonitors files.

With the default settings, once a file is converted, both the source and destination will not be reconverted by MCEBuddy (to avoid this loop). However, on user requests we have provided options to override that safety and those options are colored in Red.

Sorry! I meant to attach it! I think I have all ‘remonitor’ flags off:

ReMonitor Recorded Files -> False

mcebuddy.zip (18.0 KB)

1 Like

Looking okay so far, can you give me an example of a filename that is continuously reconverting so I can track down what’s going on?

Did you by any change clear your conversion history? That could explain why it’s reconverting everything.

Here is an example log of one that reconverted (still have 22,000 other examples )

example show.txt (27.9 KB)

Okay thanks, will investigate this and come back

I meant to add this .zip of 10 log files on the same recording in a row. Its attached, this is what I mean:

log.zip (106.0 KB)

1 Like

Sorry for the delay. I went through your logs and I see that it actually never reconverts the file from the conversion log:

WARNING> 2017-10-15T05:07:23 MCEBuddy.Engine.ConversionJob --> Destination file d:\recordings\48 Hours on ID (2010)\Season4\48 Hours on ID (2010).S04E07-Sweetheart Murders-__.mkv EXISTS, skipping conversion - SUCCESSFUL processing

I’m guessing that your question is why does it add it to the queue after it’s been converted once?

I tried to replicate your setup and I found the opposite, since the destination filename and source filename is the same it won’t convert the file because you’ve enabled the Skip reprocessing option in the conversion task expert settings which basically looks to see if there’s a destination file with the expected filename and if so it won’t process the file.

However it does create the log file because it will start the conversion and then quit after checking the options.