Quciksync and Hanbrake with Hardware acceleration selected in MCEBuddy


(Ray ) #1

I’m running 2.4 beta 9 on windows 10 pro with i7-4790k.

If I use the following in my profile and enable hardware acceleration inside the MCEBuddy process it uses quicksync and Handbrake - all works well

handbrake-video=–start-at duration:3 -e x264 --encoder-preset fast --encoder-tune film -q 20

So I though I would modify the profile for Handbrake specific quicksync commands as follows.
handbrake-video=–start-at duration:3 -e qsv_h264 --encoder-preset balanced --encoder-profile high --encoder-level 4.1 -q 20

If I enable Hardware acceleration within MCEbuddy it fails on Handbrake and goes on to mencoder, . If I disable Hardware acceleration in MCEbuddy it uses Handbrake and my qsv specific settings and quicksync works.

Should I not be able to put quicksync specific commands in my profile and enable the hardware acceleration tic in MCEbuddy? I recognize it is working with the tic off when I use those commands but it seems like it should also work with the hardware acceleration tic selected


(Goose) #2

MCEBuddy tries to “optimize” hardware settings by default, if you want to use your own hardware settings and not have mcebuddy change them, set these options in your profile:

<encoder>-VideoOptimized=true
<encoder>-UsingHardwareEncoding=<true/false>

See this topic for descriptions: