Cropping and Scaling

Request Type:
NEW FEATURE

MCEBuddy Version and Type (32bit or 64bit):

EDIT: Sorry, just found the Cropping flag and audio normalize flags in the expert settings. So I just need to find the scaling after cropping.
Oh and btw just tried out new 2.5 Beta 1. And the crop didn’t work, I fear. But conversion is truly fast on my Intel HD530.

Hi,

I just try my luck :slight_smile:

MCEBuddy is excellent, but as everywhere there is room for improvement :wink:

Two more (or actually one combined feature) would be really hitting the spot.

A crop feature that allows to remove black bars and a scaling option to resize the video after removal of ads to e.g. HD. I know crop analysis is not that trivial.

After using MCEBuddy for removal of ads, I usually manually use ffmpeg to adopt my TV movies
(ffmpeg -i “Input.ts” -map 0:v -c:v h264_nvenc -vf “crop=x:y:-x:-y,scale=1920:1080,setsar=1:1” -r 25 -crf 16 -qmin 16 -qmax 26 -f mpegts … using CUDA H.264 in my case). I know this outputs quite a good quality and thus higher file sizes.
Ususally I also normalize audio in one go for each of the audio streams of each movie (dynaudnorm=p=1:m=50:s=0:g=17).

Scaling and qmin/qmax could be fields to be entered by users, not sure what the existing quality slider exactly does and audio seems to only raise or lower volume rather than normalizing (my gain is also quite strong).

I know it is not the main purpose of MCEBuddy, but just wanted to place such a feature. This would thus allow to create the somewhat perfect recording.

Thanks
Bernd

Scaling is set via the max width slider on the conversion task page. If you want custom scaling you’ll have to create a custom profile and set the VideoOptimized flag so that mcebuddy doesn’t overwrite your profile settings.

Will need your logs to see what’s going on with the crop detection. Does it crop when you
Turn off hardware acceleration in the expert settings?

Thanks Goose,

I changed the profile and added the Video-optimized line. I moved the slider to 1920 as I want all my videos to be 1920:1080. And I unchecked the Hardware acceleration as you mentioned.
I fear, still no luck. No cropping or resizing took place. Here are some screenshots.
I see that you are converting the audio as well. Is there a way to keep original one (but that is less important)?
I know, I am doing something wrong, but I can’t see what it is.

I’ll try another one with black bars, I think this sample doesn’t have any :slight_smile:

Thanks for your kind help.


Friends.ts-Remove Ads-2019-10-17T10-31-14.1457665 02-00.log (422.5 KB)

Here another log file. HW encoding disabled slider changed to 1920.

Black bars on top and bottom. But no crop and resize. Is it possible that my sample size is too small? I will take a longer recording to test.

EDIT: A longer sample (1 hour) behaved the the same way.

Make My Day.ts-Remove Ads-2019-10-17T11-19-41.6548999 02-00.log (427.6 KB)

So a couple of things:

  1. The Max width, as it is a width limiter, it doesn’t upscale video. You source video has a resolution of Height (pixels) -> 576
    Width (pixels) -> 544
    Your output video is 544x576, so it’s the same as the source video.
  2. It isn’t cropping because you’ve told MCEBuddy that you profile video parameters are already optimized and hence it should do anything that will change those params, from your logs:

–> ffmpeg-VideoOptimized=true

See the description of VideoOptimized to understand the implications of doing this. This parameter is only used if you’ve got a highly optimized profile for a very specific purpose and you don’t want MCEBuddy to optimize it further.

Thanks for your patience Goose :upside_down_face:

Guess I misunderstood your previous post then concerning the video-optimized flag. I will have another go with changed settings again.
I guess then there is no up-scaling directly possible, is that correct? I usually scale any video (which is most often lower than 720) to 1920x1080.