App Crashing and Can't Uninstall!

#1

Fed up with trying to troubleshoot app-launching crash (worked fine then just took a dump and crashed whenever I tried to load it).

Uninstall app doesn’t seem very rugged; it throws this error:

image

It says that uninstall will continue, but it does not (tries to roll back). Repair doesn’t work either. Thoughts?

0 Likes

(Goose) #2
0 Likes

#3

Yeah, those are the kinds of steps (and robust logic) that should be built into the uninstaller app… especially for a paid app.

Still concerned about the original issue: the app was working fine, then just started to crash on launch (only error thrown was in Event Viewer, which shows that the actual MCEBuddy app is not very robust, either, with handling error conditions). I guess I’ve got that to look forward to, assuming that I can get this thing to uninstall and re-install to a state of “normal.”

Will report back progress…

0 Likes

(Goose) #5

This happens when your file system gets corrupted. MCEBuddy has been hardened over the years and handles pretty much any exception but if the files are corrupted it can’t do anything, that’s when the FAQ’s come into play.

If things are running fine and suddenly stop, something changed and most often it’s a corrupted fileystem or installer database. It’s more common than you think, hard disk partial failures, bad sectors, file system corruption etc. A quick search on the forum will show you conversations about how random crashes, hangs etc are resolved when the hardware is changed.

0 Likes

#6

Haven’t seen corruption on a journaling NTFS file system for years now. Chkdsk confirmed. Plus, I’m sure that corruption is only affecting the last piece of software that was installed. Veeerrrry coincidental. My hunch is that it’s MCEBuddy having a problem reading its own .conf file, after I did some extensive configuration within the GUI.

UPDATE: followed everything in FAQ (removing service, whacking Program Files directory, searching through indicated points in Registry and deleting related keys, picking files out of root of %HOMEPATH% [which should in an MCEBuddy folder there, instead of root] and rebooting).

Attempted clean install and guess what? Installer believes that MCEBuddy is still installed! Given choice to remove or repair, I selected remove and got this:

image.

Again, this is not due to file system corruption. I haven’t seen something so hard to uninstall since McAfee in its heyday. This is ridiculous! It’s clear that proper error handling in the app and in the uninstall app are nowhere to be seen. So, here we sit…

0 Likes

#7

UPDATE: re-ran installer after last remove failure. This time, selected repair. Voila. Now it works. How nice. Super confident in app state now.

image

Next Steps: I backed up old .conf file, so will see if that’s what was causing the app to initially crash. Will be sure to report back, because no one should have to go through this.

0 Likes