Video freezes for a few seconds in the begining

The original file plays just fine, but when running it through mcebuddy the video freezes in the beginning of the video however I can still hear audio while it “freezes”. I’ve tried reinstalling mcebuddy. Tried ver. 2.5 release 5 and 2.5 release 6. I’ve reinstalled windows, I have reinstalled video card drivers (dual 1080 Ti’s in SLi) Ive even tried on multiple pcs (alienwares M17 laptop and dell poweredge server) all give me the same results. I never had this issue til the other day. I have been racking my brain on this issue. Any help would be greatly apricated, thank you!

I can also upload the before and after video files as well if needed.

Here are my logs from mcebuddy:
Bar Rescue (2011) - S03E02 - Rock 'N Roaches.mkv-remove ads-2021-05-21T21-24-48.log (586.9 KB)

EDIT: I switched mcebuddy to showanalyzer and used customer cuts and for the most part videos no longer freeze in the beginning, however there in a few videos is a small stutter, which I can deal with… Wonder if its something with my comskip file:
comskip.ini (6.2 KB)

It looks like you’re using the trial version.

I don’t see any obvious errors on the logs. It may be a quirk in the video stream timing information (which explains the difference between Comskip and ShowAnalyzer as they will pick different spots to cut commercials) causing ffmpeg to choke. If you can upload the original video to our upload server I can take at it to see what’s going on.

@Goose I have uploaded the files to the server for you to take a look at

I have used ffmpeg and handbreak and still get the same results. I wonder if its my .comskip.ini file thats causing this

I have noticed similar behavior. The video freezes at the commercial cut point (chapter break) but the audio keeps going.

In VLC, I have to stop playback, restart it and use the mouse to jump to just after the chapter break it froze at. The video starts playing normally from that point.

It doesn’t happen all the time. And some videos it happens at every chapter break.

I’m transcoding from SD HDHR recordings to H.265/AVC in MKV format with comskip ad removal if that helps. I think the cut/merge point may not be at a ‘nice’ boundary (keyframe?) for some reason when it cuts out commercials. Maybe the cut stop/start points are not taking keyframes into account? Could it be a comskip configuration issue?

I can upload an example too if you need one, @Goose.

@Goose any progress on what the issue may be?

It looks like what @mike808 said, it’s due to keyframes at the cutpoints (or lack of) which is causing the tearing. This is an artifact from the original recording where it may not have enough keyframes.

There’s one way to try to workaround is to use the nearest keyframe which works in some cases (depending on how far it is). Try adding this to your profile:


You can find more details about this option here:

@goose forgive my ignorance as I am new to all this… what is the hell is a keyframe and how do I know what "keyframe: is the nearest?

A keyframe is a special frame in the encoding that periodically syncs up the video with the audio so that they don’t get too far out of whack as the video plays. Some video editing tools are aware of keyframes, and if you’re manually editing, you should always make your cuts on the keyframes. Video production tools can insert keyframes as they remux the video with the audio. They’re usually not something you have to fuss with. What @Goose is referring to is that wherever you got the video from, whoever produced it decided to insert those keyframes as often as their tool does that. Some are good and give you control over them (how many frames or seconds between keyframes), others are basic and just slap them in every 10 seconds or so. Whoever made your video already decided how frequent the keyframes would be inserted into the video stream to keep the audio in sync. Keep in mind there are often multiple language audio streams and 5.1 streams and so keyframes get critical keeping all of those streams in sync. For basic stereo broadcast TV fare, not so much. It just depends on the production quality of the original video and the processing tools they used to make it.

What I’m surprised is that the ad-detection cutpoints aren’t adjusted to the prior or next keyframe either as an option, or keyframes aren’t automatically added at the cutpoints. I know I’m being wand-wavey because that is probably technically hard to do, but at the same time, that is what the demux/remux tools are supposed to do automatically (ffmpeg, handbrake).

It could also be a tradeoff if requiring ad removal cutpoints to be forced to cut on keyframes or to force the demux to add keyframes at the cutpoints and then split the streams and remerge, that very well could require multiple passes through the video and that is where people get impatient.

@Goose, are there options to FFMPEG and/or Handbrake and/or avidemux to do something like that, and can that be turned into an “option” or a set of preset options that can be flipped on/off along with the appropriate info/warnings if it means multiple passes an transcodings will take X times longer. Then let people turn it on/off as they need to. For me, I would turn it on because my MCEBuddy is running at night after the recordings have been made and preparing it for later watching with Plex. I don’t record enough to have my machine bogged down all the time converting videos, so it wouldn’t bother me for the extra processing time. Especially if it meant perfect playback where they don’t “lock up” at the ad cutpoints.

@Goose adding CommercialMergeTool=avidemux seems to make it worse. About halfway through the video I loose audio. I just give up!!! I might as well as delete mcebuddy and find an alternative. Its a shame I paid money for this to not work. I dont get this, my set up has not changed and all of a sudden I get this issue. Its extremely frustrating!

@mike808 all my video files are from my plex dvr. I can use showanaylizer and its fine for the most part, minus a millisecond skip in the beginning. The same video using comskip and it starts to get screwed up. I’ve also used a few other video editing software, including sony vegas and the video is fine, so I can say with 100% certainty its not the video or the source of the video.

If you have better results with ShowAnalyzer, then stick with that. MCEBuddy can use ShowAnalyzer or Comskip.

All video software has tons of “fudge factor” code in it - from VLC to WMP to Vegas to SA to Comskip to FFMPEG to Handbrake to Avidemux to VirtualDub to all the codecs - DivX, VP8, VP9, MP2, MP4, H265, AVC, and every other video editing/transcoding product out there. And bugs. (Just read any of the forums for any of them and someone has a “weird video problem” for that just chokes whatever the software is) The fact that MCEBuddy does as good as it does for 99.999% of whatever junk OTA video we can throw at it is an achievement in itself. I’m sure there is a video file out there that MCEBuddy handles just fine and Sony Vegas chokes and pukes all over itself too. The same for VLC and Windows Media Player. Or any other tool, codec, or playback software.

I hope @Goose can give you a refund if that’s what you want. Good luck with finding a replacement and I’m sorry MCEBuddy didn’t work out for you.

@mike808 it was working perfectly for about a month and this issue just manifested out of no where. I have seen multiple people have the same issue with mcebuddy. I tried a few alternatives to mcebuddy last night and I got to say videos are being cut and covered is more accuracy then comskip + mcebuddy

@Goose would have to comment on what components or configurations for them changed in MCEBuddy from that timeframe. e.g. a new Comskip/FFMPEG/Handbrake/AviDemux/mencoder/ version was included, or different defaults put into the config files.

@Goose I am having the same exact issue. Nothing has changed in any of my setup. its been working for about a year and all of a sudden this issue came out of no where. I am begining to wonder if its an issue with mcebuddy/comskip as I am not the only one having this issue. There are others according to the forums who are having this issue. I am trying the beta release of the newest mcebuddy right now. Not sure if this matters but I was on 2.55 release

I haven’t had the issue in a while, and my use case is for timeshifting where I delete the shows after watching. So for me it isn’t a big enough trouble to bother. I just skip to just past the chapter break and continue watching in VLC. I figure that if this is a problem with the third-party cutter/remux tools (that @Goose didn’t write and doesn’t have a fix for someone else’s software) then the community supporting that tool will eventually identify the issue and possibly correct it. Such is the life of depending on open-source software developed by others.

What I will do is keep an eye out for media where it happens more than a one-off episode and then turn off my “delete original” option for that profile and see if I can save a small original (e.g. SD) and the processed version so that @Goose can take a look.

Maybe you can do the same. That may be the only way for @Goose to have any chance at identifying the tool(s) in the root cause and then reaching out to that component’s community for a volunteer to fix. Otherwise, the behavior isn’t really enough to identify which specific step is causing the key frame to be either dropped or not re-inserted at the chapter break points. It could even have to do with the container or the media - I am using MKV containers with H.265/AAC stereo streams if that helps.

Its happening for every one of my videos. I have been using HEVC MKV, I will try another profile to see if its a profile issue or not. Will keep you posted

@mike808 which profile is h265?

MKV High Quality yields the same results, freezes in the same spot, video freezes and I can hear audio. this is really getting on my damn nerves, Glad I spent money on something that works very rarely!!! I tried multiple ini files and still get the same results, this is what leads me to believe there is something going on in the background! I know its not my rig causing the issue as its a beast, 6700k, 64GB RAM and dual 1080Ti’s. just to rule out a hardware issue I turned off hardware encoding and it still gives me the same results. Kinda sucks when people say “well it works on my machine” yea that helps. and to gooses suggestion, as I did station I am new to all this I have no damn idea what he is talking about nor where to even adjust or see what he is talking about. I swear, I need to be a brain surgeon to figure this all out

trying MKV normal quality profile right now.

@mike808 would you mind sharing your comskip.ini and your profiles.conf ? I want to see if its something with those files, You did state you have no issues what so ever so in theory If I replace those files with yours I should get mine working without any issues

i’ve also just made some changes to my profile file
changes the order to: order=ffmpeg,handbrake
changes ss to: ffmpeg-video=-ss 10

after a few hours of research someone posted that changes those made a difference for them. crossing my fingers

anything I do isnt making a difference, I dont want to be editing 200+ files manually. I am a loss right now and frankly ready to pull my hair out and give up on mcebuddy if I cant get this resolved soon

@Goose can you point me in the right direction to see what the hell I am doing wrong, Again, nothing has changed in my original set up (also all files were DVR’ed using plex) which as working fine for a few months and now every video I run through comskip is freezing at one point or another.I am sorry for being persistent about this but something is a miss and I want to figure it out, as I dont feel like manually setting cut points in mcebuddy cutter for 200+ videos and run them through showanaluzer as that is VERY time consuming I have tried using ffmpeg vs handbreak and still having the same issue. At least its cutting the commercials where I want them to now so I am making progress but cant resolve the freezing issuing.

my profile.config,
profiles.conf (96.7 KB)

my comskup.ini file
comskip.ini (7.4 KB)

my mcebuddy.conf
mcebuddy.conf (6.2 KB)

all other files in config foler
history (74.3 KB)
manualqueue (15 Bytes)
mcebuddy.conf.old (3.3 KB)
profiles.conf.old (96.7 KB)
temp (2 Bytes)
tempsettings (93 Bytes)

I have tried everything I can think of and still cant resolve this issue. I am sorry to be pushy or “that guy” but I am not statisfied with “thats just the nature of beast” or “manually cut the files” I did purchase this software to use the auto commercial cutting ability and I want to get my moneys worth. If I want to manually cut the videos I would have downloaded a free software. I just want to be able to record from plex (works flawlessly), have mcebuddy pick up the file (works flawlessly), convert it to mkv (works flawlessly) and cut the commercials (freezing issue with ALL videos using comskip) and place it back on my media server (works flawlessly)

@who_cares if you ever figure this out please let me know, I am having the same exact issue you having. I too share your frustration. Everything was working beautifully then a few weeks ago when watching how its made and noticed that the video freezes as well

I didn’t state I do not have this issue. I said it is intermittent (the hardest kinds of problems to figure out) and that my use case can resolve it with a workaround during viewing.

Thanks to @fragmaster007 for letting us know there are more people having this issue. Can you share some details (same/different) on your DVR/source input, output format, and profile?

h.265 = HEVC. And h.264 = MP4 = MPEG4 (part 10).

HDTV is broadcast in MPEG-2 streams. DVDs are also in MPEG-2 streams.

I also use MKV. That might be a clue for @Goose.
I also am using comskip. I am also using HW (nVidia) transcoding.

I use a SiliconDust HDHR Quattro tuner and use the SiliconDust DVR software. I have Plex DVR (lifetime) but don’t use the DVR.

Since you experience this on every recording, and you’ve uploaded your configs and logs, that will help a bunch.

It might help to upload the “raw” original recording file and the resulting “broken” MKV for @Goose to analyze. Please pick a small/short recording that demonstrates the issue. Maybe create a new profile and crank up the compression to get a smaller file size. It just needs to record over a commercial break and the MKV exhibit the broken playback behavior.

With the before/after media, the logs and config, that’s probably enough to learn more about where the issue might be.

Fingers crossed.

@mike808 I have a silicondust homerun prime. with @who_cares stating he is seeing the same behavior I hope this issue gets some traction, @Goose

I just downloaded the most recent version of comskip directly from their site and copy and pasted everythikng from the new folder to the one in the mcebuddy folder (minus my comskip.ini file since its cutting commercials just fine) I am running mcebuddy. Fingers crossed this resolves the issue. Will update once mcebuddy is finished with my video.

@Goose @mike808 going to install 2.5.7 beta and see if that fixes the issue

not sure if it was because I switched to 2.5.7 beta or because I made a change to a few settings but it looks like its now working!!! no more freezing, at least from the 4 videos I tried. Now I just need to fiddle with cutting the ending of the previous show and the beginning of the next show from my videos

god damn it!!! that was short lived. its freezing again!!! WTF is going on!!!

how I had it before: plex records to a folder, mcebuddy picks up that file and converts it to mkv then removes the commercials

This is my hail mary pass here before I give up and wait for @Goose to take a deeper look, I set mcebuddy to move the files to a folder where it organizes all the videos by show, then remove the commercials then coverts to mkv.

EDIT: I think that might be the issue. so far 4 for 4 with no freezing. will wait till later on today to make a judgement call. I have like 30 episodes scheduled to record today on plex. Will let you know once I get a bigger sample size