Utilisation de lecteurs mappés vers un serveur NAS sur Windows 10

J’ai tout lu sur votre forum de discussion et j’ai tout essayé sans succès. J’ai un NAS avec Plex et le DVR en direct configuré, il capture donc depuis mon HomerunConnect via Plex vers un partage NAS. J’aimerais que MCEBuddy surveille ce partage, convertisse les fichiers en un format plus petit, supprime les publicités et les dépose dans un autre dossier sur le même lecteur de partage NAS. J’ai essayé d’aller dans PARAMÈTRES GÉNÉRAUX et d’ajouter l’authentification réseau en utilisant mes identifiants de lecteur mappé vers mon NAS, puis de mettre à jour les profils avec uniquement les identifiants de mon poste de travail local. J’ai essayé de tous les laisser en tant qu’invité. J’ai essayé d’utiliser les identifiants du partage de lecteur mappé dans les profils. J’ai essayé tout cela avec la version standard et la version en ligne de commande. J’ai même téléchargé SystemInternalsSuite et créé un lecteur mappé sous mon compte SYSTEM local pour qu’il soit mappé au système. Rien ne fonctionne. À court d’idées et très frustré

mcebuddy.log (811.0 KB)

C’est probablement votre problème. Vous utilisez un nom de lecteur mappé. Les lecteurs mappés n’existent pas dans le contexte système, uniquement dans le contexte de connexion utilisateur, et MCEBuddy s’exécute en tant que service système dans le contexte système.

Search Path -> P:\DVR

Changez votre chemin vers un chemin réseau comme \\network\share et cela devrait fonctionner correctement avec les identifiants. Même chose pour votre dossier de destination.

Consultez la page des problèmes courants pour plus de détails sur ce sujet.

Assurez-vous également que la date et l’heure de votre NAS correspondent à celles de l’ordinateur. Un utilisateur a noté que lorsque les dates et heures ne correspondaient pas, l’authentification échouait.

Je l’ai aussi essayé comme ça avant et j’obtiens le même résultat. Existe-t-il une version Linux de ce logiciel ?

RBoy

2 septembre
C’est probablement votre problème. Vous utilisez un nom de lecteur mappé. Les lecteurs mappés n’existent pas dans le contexte système, uniquement dans le contexte de connexion utilisateur, et MCEBuddy s’exécute en tant que service système dans le contexte système.

> Search Path -> P:\DVR

Je crois que j’ai réglé le problème. J’ai créé un nouveau moniteur et une nouvelle destination, j’ai mis les identifiants dedans puisque mon disque est déjà mappé, et presto, ça a fonctionné cette fois.

J’ai eu des problèmes avec ça aussi, j’ai dû faire des glisser-déposer de fichiers pendant toute la dernière saison, alors j’ai décidé d’essayer de régler ça cette saison. J’ai une box Kodi avec un lecteur USB monté qui est partagé \\kodiname\My Passport\Recordings
Je reçois cette erreur qui, je pense, est liée au nom du partage, très probablement à l’espace dans “My Passport” qui n’est pas pris en charge ?
ERREUR : Le format du chemin d’accès donné n’est pas pris en charge.

Si l’espace est le problème, je ne sais pas comment renommer un lecteur USB partagé et monté dans Kodi, mais ce serait déjà un début.

J’ai essayé de mapper le lecteur d’abord, puis de pointer le moniteur vers R:, mais j’obtiens
ERREUR : Impossible de trouver une partie du chemin d’accès ‘R:\’.

Je sais que ce doit être une petite erreur quelque part, mais je me creuse la tête depuis des mois.

Merci

Avez-vous vu ce post :

Les lecteurs mappés n’existent pas dans l’espace système et MCEBuddy s’exécute dans l’espace système. Vous devez utiliser des URL réseau comme \\server\sharename ET vous devez entrer les identifiants de connexion pour le partage distant (cherchez l’icône en forme de clé à côté).

Essayez de terminer vos chemins avec et sans \

Cela vous aidera si vous joignez votre fichier journal ou l’erreur complète et le chemin exact que vous avez utilisé dans vos paramètres.

Salut RBoy,
Oui, j’ai bien vu ce message. Je n’utilise pas de lecteurs réseaux mappés, mais j’ai essayé parce que j’ai lu le dernier message de Jeffrey : il a réussi à le faire fonctionner en ajoutant simplement un second emplacement. J’utilise habituellement l’adresse IP ou le nom de partage, mais je ne sais pas si ces deux méthodes fonctionnent de la même manière.

Voici le fichier journal en testant les deux façons. Je suis certain d’avoir un problème d’identification quelque part ; c’est déroutant de les avoir à différents endroits, un sous Système, un pour la surveillance, etc. J’obtiens une erreur différente selon que j’utilise l’adresse IP ou le nom du serveur.

mcebuddy.log (57,1 Ko)

Merci

Gardons cela un peu plus simple puisque j’ai eu d’autres erreurs au début de ce journal, j’essaie trop de combinaisons différentes. Cette configuration semble correcte, j’obtiens simplement l’erreur « le format du chemin donné n’est pas pris en charge ». Le partage se trouve sur un Odroid C2 utilisant LibreElec monté avec un disque externe USB, au cas où le « format du chemin donné » ferait référence à un problème avec la structure du répertoire source.

mcebuddy.log (20,6 Ko)

Hmm je me demande si l’adresse IP est la cause du problème. Essayez d’utiliser un nom de machine à la place et je vais aussi vérifier.

Oui, j’essayais d’abord avec le nom de la machine, c’est là que j’ai remarqué l’erreur « le format du chemin n’est pas pris en charge ». J’ai lu certains messages évoquant des problèmes Unicode, je ne suis pas sûr du format auquel il est fait référence dans ce cas. Je vais essayer de découvrir comment renommer le partage en un format plus simple sur la machine kodi, quelque chose sans l’espace dans « My Passport ».

Voici le journal avec le nom de la machine utilisé.
mcebuddy.log (22,6 Ko)

D’accord, ça a fonctionné et c’était plus simple que je ne le pensais. Je l’ai branché sur le bureau, gestion des disques → propriétés et j’ai changé le nom en “Passport”. Je l’ai rebranché sur la machine Kodi, il s’est monté avec le nouveau nom, puis j’ai changé l’emplacement de surveillance dans MCEBuddy vers le nouveau nom et il a récupéré tous les enregistrements immédiatement. Je pensais que j’allais devoir utiliser SSH ou créer un fichier de configuration de démarrage personnalisé. Cela me fera gagner du temps une fois que toutes les nouvelles émissions seront diffusées et enregistrées. Je pense avoir trouvé l’astuce Unicode sur des fils de discussion de programmation C#, je ne me souviens pas avoir vu quoi que ce soit sur les formats de nommage acceptables dans les sections de dépannage de MCEBuddy. Cela pourrait être un conseil utile si c’est le cas.

Merci

Vous utilisiez donc un nom Unicode pour la machine ou le point de montage ?

Pour le montage, le disque externe de Western Digital avait le nom prédéfini « My Passport » pour le lecteur. J’ai renommé le disque externe en « Passport ».

Mon chemin de partage était donc :
\\lkodi\My Passport\Recordings

Je l’ai mis à jour en :
\\lkodi\Passport\Recordings

J’essaie de faire fonctionner cela depuis de nombreuses heures. J’ai un nouveau serveur raspberrypi exécutant le serveur Plex dans OMV. J’essaie de remplacer mon serveur Plex Windows, où j’ai MCEBuddy2x qui convertit à la volée et fait un excellent travail. Je n’aurais jamais pensé que MCEBuddy2x occuperait la majeure partie de mes efforts de configuration.
Avec mes moniteurs configurés pour utiliser \\server\share, je reçois des flux d’erreurs comme celle-ci…
ERROR> 2018-05-20T21:36:45 MCEBuddy.Engine.QueueManager → Impossible de rechercher des fichiers dans l’emplacement \\raspberrypi\Media\Movies pour la tâche de surveillance Films
ERROR : Le nom réseau n’a pas pu être trouvé.
Je me demande si cela est lié au fait que la découverte réseau de mon Explorateur Windows n’affiche pas le serveur OMV dans le groupe de travail. J’avais essayé cela avec un lecteur mappé, ce que je sais maintenant ne fonctionne pas.

Oui, Windows ne parvient pas à résoudre le nom/chemin de l’ordinateur

Vous avez raison, les lecteurs mappés n’existent pas dans l’espace Système/Kernel où s’exécute MCEBuddy, donc vous ne pouvez pas utiliser de lecteurs mappés sauf si vous lancez le moteur MCEBuddy depuis votre compte utilisateur et non en tant que service. Voir cette FAQ :

Sur ma machine

J’ai essayé pendant longtemps de faire fonctionner UNC / lecteur mappé

Solution : Entrez le chemin du lecteur dans MCEBuddy, puis cliquez sur l’icône en forme de clé à droite de l’endroit où cela est saisi et tapez Guest dans le nom d’utilisateur si vous n’avez pas d’informations de connexion. (ou remplissez les détails de connexion ici)

Rien à voir avec Windows ou l’espace système, il manque juste le mot “Guest”

C’est correct et la meilleure option, citant la FAQ sur l’utilisation des lecteurs réseau mappés :