HDHomeRun h265 profile


#1

I figured I would share a new profile I am working on. It converts files to the HDHomerun h265 format. I have only briefly tested it and it currently only supports ffmpeg. Nvenc is working with it. I am not an expert in handbrake so I will leave that part up to someone else. Anyway enough chatting here it is.

[HDHomeRun H.265]
Description=Use this to remove the commercials and convert the source video into a SiliconDust HDHomeRun compatible MPG file with (H.265/AAC) video/audio.
order=ffmpeg 
ffmpeg-general=-threads 0
ffmpeg-video=-vf yadif=0:-1:1,hqdn3d -vcodec libx265 -preset medium -x265-params crf=18 -f mpegts -map 0:v -sn 
ffmpeg-audio=-acodec libfdk_aac -ab 160k -map 0:a 
ffmpeg-ext=.ts 
ffmpeg-audiodelay=skip  
PreConversionCommercialRemover=true 
RenameExt=.mpg

(Goose) #2

Great work, give this a whirl and let us know if it works:

handbrake-general=--decomb --denoise --loose-anamorphic --verbose=2
handbrake-video=--start-at duration:3 -e x265 --encoder-preset medium -q 18
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.ts
handbrake-audiodelay=skip

Add this to your profile above and you will have to change the order to include handbrake


#3

I am glad you like the profile. Unfortunately the only system that I have with enough power to run a conversion and a intel gpu is haswell based. Hence why I like nvenc. If you run the conversion, I would be more than happy to test the output.


(Goose) #4

I am curious though why you switched from ac3 to aac. Is that the default on HDHR?


#5

I initially tried it with ac3 audio unfortunately there was a lot of noise in the stream when I played it back with the hdhomerun windows 10 app. Switching to aac audio seemed to clean this up. I am not sure what is the default audio format for h265 video on hdhomerun. I am on fios and do not receive any h265 channels. Fios is very behind the times. They don’t even support ipv6. However both h264 and mpeg2 use ac3 audio.


(Goose) #6

Okay and I just realized that you’re missing the ffmpeg-audioac3 line from your profile. That’s what MCEBuddy will use if the source video has an ac3 audio stream (which most videos today).

I’ll run a test and upload it for you to test.


#7

I ran a conversion of a mpeg2/ac3 file to h265/aac using nvenc without that line and it worked fine. My guess is that line is only necessary if it is using different parameters from the ffmpeg-audio line. Please let me know what directory/server it is in as it has been a while since I have shared files on mcebuddy.


(Goose) #8

That’s correct, if you want separate settings for converting if the source is ac3 and separate for non ac3 you add the audioac3 line, otherwise it’ll use the audio line for both.


#9

Sounds good to me. Let me know when you get that test file uploaded.


#10

It plays fine. Which I find surprising as you switched back to ac3 audio. Also I don’t know if this was intentional or not but your metadata was way off. It said “i love lucy” but the show was about skiing.


(Goose) #11

Yeah those were our test files, we like to mix things up to see how the buddy handles it. Thanks for testing em out. Yes we moved back to AC3 because that what we think is default with HDHR based on some samples we’ve received. The improvement could also be due to the fact that we’ve got new builds of handbrake and ffmpeg in the next BETA which are optimized for hardware encoders and improved software encoders.


#12

I’ve been using this NVENC H265 profile for some time - works great!

[----------------------]
[MKV HVEC Constant Quality]
Description=WARNING: Handbrake Constant Quality encoding (25) with Nvidia HVEC.
order=ffmpeg, handbrake
AllowH264CopyRemuxing=true
FixedResolution=true
AutoDeinterlace=true
ffmpeg-UsingHardwareEncoding=True
ffmpeg-general=-threads 0 -hwaccel auto
ffmpeg-video=-ss 9 -c:v hevc_nvenc -crf 25 -map 0:v
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384k -map 0:a
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
handbrake-UsingHardwareEncoding=true
handbrake-general=--decomb --denoise="weak" --loose-anamorphic --verbose=2 -T -O
handbrake-video=--start-at duration:3 -e x265 -q 18 
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mkv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

(Goose) #13

Cross linking: