# Using mapped drives to NAS server on Windows 10

**URL:** https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550
**Category:** General Support / Questions
**Tags:** nas
**Created:** [September 2, 2017, 12:29pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550 "2017-09-02T12:29:41Z")
**Posts on this page:** 17
**Page:** 1

<div class="post-metadata">

### Author: ![Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/j/e19b73/32.png) [@Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/u/Jeffrey_Wiggins)
#### Post date: [September 2, 2017, 12:29pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/1 "2017-09-02T12:29:42Z")

</div>

So i have read everything I can find on your discussion site and tried them all with no success. I have a NAS with Plex and Live TV DVR setup so it captures from my HomerunConnect via Plex to a NAS share. Iwould like MCEBuddy to monitor that share and convert the files to smaller format and remove commercials and drop it in a different folder on that same NAS share drive. I have tried going into the GENERAL SETTINGS and adding the network authentication using my map drrive creds to my NAS and then updating the profiles with just my local workstation user creds. I have tried leaving them all as guest. I have tried using the map drive share creds in the profiles. I have tried all of this using the standard and command line version. I even went and got SystemInternalsSuite and created a map drive under my local SYSTEM account so it would be mapped to the system. Nothing works. Out of ideas and very frustrated

[mcebuddy.log](https://mcebuddy-discussion-forum.s3.amazonaws.com/original/1X/01297b0ff98a164ac854d78b5f2f39e290264624.log) (811.0 KB)

---

<div class="post-metadata">

### Author: ![RBoy](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/r/2bfe46/32.png) [@RBoy](https://discussion.mcebuddy2x.com/u/RBoy)
#### Post date: [September 2, 2017, 3:47pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/2 "2017-09-02T15:47:24Z")

</div>

This is likely your problem. You are using a mapped drive name. Mapped drives don’t exist in system context, only in user login context and MCEBuddy runs as a system service in system context.

```auto
Search Path -> P:\DVR

```

Change your path to a network path like `\\network\share` and it should work fine with the credentials. Same for your destination folder.

See the [Common issues](https://discussion.mcebuddy2x.com/t/25) page for details on this topic.

> [@MCEBuddy FAQ - Common Issues and Errors](https://discussion.mcebuddy2x.com/t/mcebuddy-solution-to-common-errors-and-issues/25):
>
> > **Table Of Contents:**
> >
> > \<a href="https://discussion.mcebuddy2x.com/t/25#mcebuddy-doesnt-capture-all-my-commercials-or-cuts-too-littlemuch-of-the-commercials-1"\> MCEBuddy doesn’t capture all my commercials or cuts too little/much of the commercials\</a\> \<a href="https://discussion.mcebuddy2x.com/t/25#with-newer-mcebuddy-builds-2315-and-later-the-video-conversions-fail-randomly-2"\> With newer MCEBuddy builds (2.3.15 and later) the video conversions fail randomly\<…

Also ensure that your NAS date time is matching the comouter date time. One user had noted that the date times didn’t match the authentication fails.

---

<div class="post-metadata">

### Author: ![Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/j/e19b73/32.png) [@Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/u/Jeffrey_Wiggins)
#### Post date: [September 2, 2017, 4:29pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/3 "2017-09-02T16:29:59Z")

</div>

Tried it that way as well before and I get the same result. Is there a Linux version of this?

> ![](http://discussion.mcebuddy2x.com/letter_avatar_proxy/v2/letter/r/2bfe46/45.png "RBoy")
> 
> [RBoy](http://discussion.mcebuddy2x.com/u/rboy)
> 
> September 2  
> This is likely your problem. You are using a mapped drive name. Mapped drives don’t exist in system context, only in user login context and MCEBuddy runs as a system service in system context.

```auto
> Search Path -> P:\DVR

```

---

<div class="post-metadata">

### Author: ![Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/j/e19b73/32.png) [@Jeffrey\_Wiggins](https://discussion.mcebuddy2x.com/u/Jeffrey_Wiggins)
#### Post date: [September 2, 2017, 7:55pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/4 "2017-09-02T19:55:18Z")

</div>

Believe i fixed it. I built all new monitor and destination and put creds in since my drive is mapped already and presto it worked this time

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 12, 2017, 11:33pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/5 "2017-09-12T23:33:58Z")

</div>

I’ve been having trouble with this like crazy too, I had to drag and drop files in all last season, so I figured I’d try to nail it down this season. I have a Kodi box with a mounted USB drive that is shared \kodiname\My Passport\Recordings  
I get this error which I think has to do with the share name, most likely the space in My Passport not being supported?  
ERROR : The given path’s format is not supported.

If the space is the problem, I’m not sure how to rename a shared mounted USB drive in Kodi, but at least that’d be a start.

I’ve tried mapping the drive first, then pointing the monitor to R:, but I get  
ERROR : Could not find a part of the path ‘R:\’.

I know it has to be one little mistake somewhere, but I’ve been racking my brain for months.

Thanks

---

<div class="post-metadata">

### Author: ![RBoy](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/r/2bfe46/32.png) [@RBoy](https://discussion.mcebuddy2x.com/u/RBoy)
#### Post date: [September 13, 2017, 1:12am UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/6 "2017-09-13T01:12:26Z")

</div>

Did you see this post:

> [@Using mapped drives to NAS server on Windows 10](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/2):
>
> This is likely your problem. You are using a mapped drive name. Mapped drives don’t exist in system context, only in user login context and MCEBuddy runs as a system service in system context. Search Path -\> P:\DVR Change your path to a network path like \\network\share and it should work fine with the credentials. Same for your destination folder. See the Common issues page for details on this topic. Also ensure that your NAS date time is matching the comouter date time. One user had note…

Mapped drives don’t exist in system space and MCEBuddy runs in System space. You have use Network URL’s like `\\server\sharename` AND you have to enter the login credentials for the remote share along with it (look for the key icon next to it).

Try ending your path’s with and without a \

It will help if you attach your log file or the complete error and exact path you’ve used in your settings.

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 13, 2017, 4:22am UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/7 "2017-09-13T04:22:30Z")

</div>

Hi RBoy,  
Yeah, I did see that post. I don’t use mapped drives, but was trying it because I read Jeffrey’s last post as he got it working, he just had to add a second location. I usually use the IP address or share name, but I’m not sure if those both work the same

Here’s the log file trying both ways. I’m sure I have a login messing things up somewhere, it gets confusing having them in different spots, one under System, one for monitoring, etc. I do get a different error when using the IP address vs. server name.

[mcebuddy.log](https://mcebuddy-discussion-forum.s3.amazonaws.com/original/1X/39cb6218ab147a9caa7ea227e1f1c7ce6388c39a.log) (57.1 KB)

Thanks

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 13, 2017, 5:04am UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/8 "2017-09-13T05:04:47Z")

</div>

Lets keep this a little simpler since I had other errors at the beginning of that log, I’m trying too many different combinations. This setup looks correct, just getting the “given path’s format is not supported” error. The shared location is on an Odroid C2 using LibreElec mounted with a USB external drive, in case the “given path format” is referencing an issue with the source directory’s structure.

[mcebuddy.log](https://mcebuddy-discussion-forum.s3.amazonaws.com/original/1X/f38144682c7f4051397c286ee3ccf9c36338c5fa.log) (20.6 KB)

---

<div class="post-metadata">

### Author: ![RBoy](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/r/2bfe46/32.png) [@RBoy](https://discussion.mcebuddy2x.com/u/RBoy)
#### Post date: [September 13, 2017, 1:07pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/9 "2017-09-13T13:07:39Z")

</div>

Hmm I’m wondering if the IP address is causing the issue. Try using a machine name instead and I’ll also try to check

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 13, 2017, 4:47pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/10 "2017-09-13T16:47:35Z")

</div>

Yeah, I was trying the machine name first, that’s where I noticed the “path’s format is not supported” error. I’ve read some posts mentioning Unicode issues, not sure what the format is being referred to in this case. I’ll try finding out how to rename the share to a simpler format on the kodi machine, something without the space in “My Passport”.

Here’s the log with the machine name being used.  
[mcebuddy.log](https://mcebuddy-discussion-forum.s3.amazonaws.com/original/1X/c830d9c3a2e949096a6fd0db90c09cb5f037e5fb.log) (22.6 KB)

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 13, 2017, 5:13pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/11 "2017-09-13T17:13:55Z")

</div>

Okay, that worked and was easier than I thought. Plugged it into the desktop, disk management-\>properties and changed the name to “Passport”. Plugged it back into the kodi machine, it mounted with the new name, then changed the monitor location in MCEBuddy to the new name and it grabbed all the recordings right away. I thought I was going to have to SSH or build some custom boot config file. That’ll save me some hassle once all the new shows air and record. I think I found the Unicode tip on some C# programming threads, I don’t remember seeing anything about acceptable naming formats in any of the MCEBuddy troubleshooting sections. Might be a useful tip if that is the case.

Thanks

---

<div class="post-metadata">

### Author: ![RBoy](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/r/2bfe46/32.png) [@RBoy](https://discussion.mcebuddy2x.com/u/RBoy)
#### Post date: [September 13, 2017, 10:11pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/12 "2017-09-13T22:11:07Z")

</div>

So you were using a Unicode name for the machine or mount ?

---

<div class="post-metadata">

### Author: ![StitchedChin](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/stitchedchin/32/1390_2.png) [@StitchedChin](https://discussion.mcebuddy2x.com/u/StitchedChin)
#### Post date: [September 13, 2017, 10:40pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/13 "2017-09-13T22:40:11Z")

</div>

For the mount, the external drive from Western Digital had the name “My Passport” preset for the drive. I renamed the external drive to “Passport”.

So my share path name was:  
\lkodi\My Passport\Recordings

I updated it to:  
\lkodi\Passport\Recordings

---

<div class="post-metadata">

### Author: ![ronwes113890](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/r/5e9695/32.png) [@ronwes113890](https://discussion.mcebuddy2x.com/u/ronwes113890)
#### Post date: [May 21, 2018, 4:57am UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/14 "2018-05-21T04:57:34Z")

</div>

I have been trying to get to work for many hours now. Have a new raspberrypi server running Plex server in OMV. I am trying to replace my Windows Plex server, where I have MCEBuddy2x converting on the fly, and doing a great job. I never would have expected that the MCEBuddy2x would occupy most of my configuration efforts.  
With my monitors setup to use \server\share, I am getting steams of errors like this one…  
ERROR\> 2018-05-20T21:36:45 MCEBuddy.Engine.QueueManager --\> Unable to search for files in location \raspberrypi\Media\Movies for monitor task Movies  
ERROR : The network name cannot be found.  
I wonder if it is related to my Windows Explorer Network discovery not showing the OMV server in the workgroup. I had been trying this with a mapped drive, which I now know doesn’t work.

---

<div class="post-metadata">

### Author: ![Goose](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/g/5f9b8f/32.png) [@Goose](https://discussion.mcebuddy2x.com/u/Goose)
#### Post date: [May 22, 2018, 1:59am UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/15 "2018-05-22T01:59:56Z")

</div>

> [@ronwes113890](#):
>
> I wonder if it is related to my Windows Explorer Network discovery not showing the OMV server in the workgroup

Yes, windows can’t resolve the computer name/path

> [@ronwes113890](#):
>
> I had been trying this with a mapped drive, which I now know doesn’t work.

You’re right mapped drives don’t exist in System/Kernel space where MCEBuddy runs, so you can’t use mapped drives unless you run the MCEBuddy engine from your user account and not as a service. See this [FAQ](https://discussion.mcebuddy2x.com/t/25):

> [@MCEBuddy FAQ - Common Issues and Errors](https://discussion.mcebuddy2x.com/t/mcebuddy-solution-to-common-errors-and-issues/25):
>
> > **Table Of Contents:**
> >
> > \<a href="https://discussion.mcebuddy2x.com/t/25#mcebuddy-doesnt-capture-all-my-commercials-or-cuts-too-littlemuch-of-the-commercials-1"\> MCEBuddy doesn’t capture all my commercials or cuts too little/much of the commercials\</a\> \<a href="https://discussion.mcebuddy2x.com/t/25#with-newer-mcebuddy-builds-2315-and-later-the-video-conversions-fail-randomly-2"\> With newer MCEBuddy builds (2.3.15 and later) the video conversions fail randomly\<…

---

<div class="post-metadata">

### Author: ![MickyDooDah](https://discussion.mcebuddy2x.com/user_avatar/discussion.mcebuddy2x.com/mickydoodah/32/857_2.png) [@MickyDooDah](https://discussion.mcebuddy2x.com/u/MickyDooDah)
#### Post date: [December 20, 2018, 6:04pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/16 "2018-12-20T18:04:10Z")

</div>

On My machine

Tried for ages to get UNC / Mapped dirve working

Solution: Enter the drive path in MCEBuddy, then click the key icon to the right of where this is entered and type Guest in the Username if you have no login information. (or fill in any login details there)

Nothing to do with windows or system space, just missing the word “Guest”

---

<div class="post-metadata">

### Author: ![Goose](https://discussion.mcebuddy2x.com/letter_avatar_proxy/v4/letter/g/5f9b8f/32.png) [@Goose](https://discussion.mcebuddy2x.com/u/Goose)
#### Post date: [December 20, 2018, 6:29pm UTC](https://discussion.mcebuddy2x.com/t/using-mapped-drives-to-nas-server-on-windows-10/550/17 "2018-12-20T18:29:27Z")

</div>

That’s correct and the best option, quoting from the [FAQ](https://discussion.mcebuddy2x.com/t/25) on how to use network mapped drives:

> [@MCEBuddy FAQ - Common Issues and Errors](https://discussion.mcebuddy2x.com/t/mcebuddy-faq-common-issues-and-errors/25/1):
>
> _To summarize, these are the options:_
> 
> 1. When MCEBuddy is running as a LocalSystem service, to access network shares that have usernames and passwords you need to enter the username and password for each share separately in MCEBuddy. Use a fully qualified network path in MCEBuddy like `\\<machine or IP Address>\<share name>` and enter the `username` and `password` credentials for that path in MCEBuddy by clicking on the credentials ( ![UserCredentials](https://mcebuddy-discussion-forum.s3.dualstack.us-east-1.amazonaws.com/original/1X/7ec35d38fec58546c7df9d4ec45059d3a4b1e053.jpeg) ) icon next to the path. Do not use your mapped drives (e.g. Z:) since they don’t exist outside your user login session
