[BUG] How to keep only English subtitles

I’ve read through most of the posts in this topic, but when I select “Extract Subtitles…” option and the “Add subtitles…” option, it keeps ALL subtitles. I did also select English as my audio language. The video i just converted had 3 subtitle streams “eng, spa, fre” labelled correctly, but all of them are in the new mp4 (along with 3 srt files apropriately named for their language).

Conversion log ?

Sorry, I just uploaded it to the ftp server under a folder jangelj
Its called testvideo.

Thanks for any insight. Also, is it possible to scan for foreign language tracks and burn them? I know handbrake can do it (I’ve done it with another frontend of handbrake), but i am not sure how to put that into my custom profile for MCE. I think it scans and uses subtitle track that is used less than 10% of the video).

Much appreciated!

It appears to be working as expected. It found 3 subtitle tracks and extracted all 3 of them and then added them to the final converted file since the add subtitle option was enabled. I think you’re confusing the Audio track selection with the subtitle track selection.

As for burning them yes it’s possible, use the SubtitleBurn option in the profile. See this topic for details MCEBuddy - Advanced Settings, Commands and Tweaking

Sorry about that Goose. Thanks for the reply. But I had read in this thread

that the language selection applied to both Audio and subtitles. Is that no longer the case?

If so, is there any way to keep ONLY the English subs? I have a movie that has 22 subtitles and I only need one of them.

Thanks for your patience as I tweak my process to make it more automated.

You’re correct, I’m moving this to a bug status. It should be fixed in today’s 2.5.3 BETA build.

Goose. Thanks so much for looking into this, responding, an offering a fix so fast. I’ve read through quite a bit of the discussions and you are always quick to respond and offer advice. It is much appreciated.

I’ll check out the 2.5.3 Beta tonight.

This appears to be working perfectly now. Thanks, Goose.