[BUG] EDL File UTF-8 BOM Encoded causing Kodi initial skips


#1

I recently updated MCEBuddy from 2.4.1 to 2.4.9 (and I had Comskip donator 81.092, but now use embedded Comskip that comes standard 82.003). I’ve noticed that all of my “old” EDL files are UTF-8 encoded when I open them in Notepad++, but all “new” EDL files are UTF-8 BOM encoded. When I play back recordings in Kodi, the “UTF-8 BOM” EDLs have an issue where the first value of the first line is ignored, and thus the video immediately jumps to the time of the second value. For example: “47.124 101.254 3” in the first line of my EDL file skips straight to 101.254 seconds into the recording right away. Can anyone confirm at least that the encoding output may have changed? If so, is there any way to force UTF-8 instead as the output? Thanks.


(Goose) #2

That’s interesting. MCEBuddy does add a BOM while cleaning up EDL files.

Technically this would be a Kodi bug as UTF-8 files may include a BOM and Kodi should be able to process it.

I’ll open a ticket to see if we can skip adding the BOM to the UTF-8 file to patch around this.


(Goose) #3

With the next 2.4.10 BETA build it won’t include the BOM byte in the EDL file but you should report it to Kodi as the specifications allow for BOM bytes in UTF-8 files (it’s pretty standard)


#4

Thanks for the quick response. Is adding a BOM new-ish to MCEBuddy? I have a friend who uses 2.4.7 and it sounds like his EDL files are straight UTF-8. Just curious. Also, it may be a specific PVR addon in Kodi with the issue, ServerWMC/pvr.wmc. In looking at their source, it appears that it expects 3 arguments on the first line, and perhaps the first bytes of the BOM-type file is interfering with that. I’ll post on Kodi PVR forums as well, but that may be a trickier fix to get implemented. From what I’ve read, BOM causes issues/confusion with lots of other apps, just wondering if it adds value to MCEBuddy. Thoughts?


(Goose) #5

It was automatically added while writing UTF-8 files when we upgraded some of the .NET libraries some time ago. I’ve disabled it as it doesn’t impact MCEBuddy either way currently. However in future if any of the supporting apps need it we may need to re-enable it so it’s better that Kodi fixes it anyways.


#6

Cool, thanks for the explanation, and the fix. I’ve posted in one of the Kodi PVR forums about it. Let me know if you’d like me to test anything, I’d be happy to.


#7

Just to follow up. I installed the 2.4.10 Beta from 3/13/19. So far, my EDL files are now UTF-8 and appear to play nicely again with Kodi. Thanks so much for the turnaround on this, I appreciate it.