[BUG] Conversions won't stay paused

Occasionally I need to pause conversions, but I’ve noticed with the last few builds of MCEBuddy that they automatically resume themselves. Is that by design, and is it something that can be disabled? Obviously if I pause a conversion I would prefer to resume it myself.

Do you have a start/stop time scheduled in General Settings under Scheduling?

I just double checked and I do not have any scheduling set up.

Okay, because that is what caused this issue with me in the past. Anything in the mcebuddy.log or conversion log file indicate why it resume? Is there any commonality on how long it stays paused? Is this on a desktop or laptop?

The conversion and mcebuddy logs show nothing out of the ordinary. However in the Windows Events log I see several entries about a power status change. But this Windows 8.1 PC has been online for 9 straight days, and none of the times listed correlate with when I paused the conversions yesterday, so I don’t think they’re related. I have another conversion that should happen tomorrow; I’ll pause it and see how long it takes to be automatically resumed.

If you have Suspend on battery checked I wonder if the power state changes you are mentioning are causing it to resume if it thinks it’s no longer on battery. No clue, just throwing ideas out there. You can pause it without any jobs running also, it just won’t pickup new files but will remain in a paused state. This is a weird one. I’ve had it paused on my main gaming machine for days and days without issue.

1 Like

Today I tried to duplicate my issue, but can’t. I added 4 shows to the queue, let it work for a couple minutes, then paused it. It’s stayed paused for over 3 hours now. The only change I made to MCEBuddy was to uncheck “Allow Sleep”, but I can’t see that changing whether it stays paused or not. At this point I’m going to leave it as is and see what happens this weekend (when shows are added automatically .vs manually).

That’s correct, if MCEBuddy received a power restored/AC online event from Windows it resumes the conversions. This is basically for computers on UPS’s and laptops.

MCEBuddy has an option to automatically suspend the conversions if Windows reports the computer is running on battery power when Suspend on battery is enabled.

However it always resumes if paused when A/C power is restored or the computer wakes up from sleep/hibernation, irrespective of whether that option is checked.

Understood, however that option was never checked.

Will see if that can be corrected in the next 2.5.6 BETA update. If the option isn’t checked it shouldn’t assume the user wants MCEBuddy to resume if paused (right now it does).

Maybe a pause method needs to be stored. And a priority designation.
Manual Pause - Highest Priority - Only manual resume allowed
Schedule Pause - Medium Priority - Manual and Schedule resume allow it to resume
Power Pause - Lowest Priority - Manual, Power and Schedule (with option?) allow it to resume

Okay, so it wasn’t just my imagination then lol. Maybe yesterday when I tried to duplicate the issue, there just wasn’t a Windows event triggered and that’s why everything stayed paused.