[BUG] Comskip INI values not being applied

comskip

#1

Hi All, I have added “edl_skip_field=3” to the end of the comskip.ini so that it plays better with Kodi. I used the Comskip GUI editor to adjust the value and save the ini. I have also made sure that under expert settings MCEBuddy is pointing to this INI file. For some reason the changes are not being reflected when MCEBuddy converts a video. Has anyone had issues with this before? Am I missing a setting in MCEBuddy?

Edit: I think it has something to do with MCEBuddy because when I change my settings to no ad remover it is still creating an EDL file. Any ideas?

Thanks


Disable EDL Creation
(Goose) #2

That’s because in MCEBuddy cut sections are always referred to as 0 when it creates an EDL file.
If it’s using a Comskip generated EDL file them it should retain the 3.

Attach your conversion log to see what’s going on


#3

Thanks for the response. I have uploaded two log files to the ftp site (ftp://upload.mcebuddy2x.com/blahdc/)

Dinosaur Train_no_comskip.log : This file has no ad remover but still produces an EDL file upon conversion.
Dinosaur Train_comskip.log : This file has the comskip ad remover enabled. I have also adjusted my comskip.ini so that edl_skip_field is set to 3. The edl files produced from this conversion still generate a skip field of 0.


(Goose) #4

Your source file has an EDL file present along with it so MCEBuddy is copying it to the output.

INFORMATION> 2018-04-09T19:33:15 MCEBuddy.Engine.ConversionJob --> Found existing EDL file and saved it

Again you source file has an EDL file present with it so it’s using that instead of running Comskip.

INFORMATION> 2018-04-09T20:28:37 MCEBuddy.CommercialScan.Scanner --> Found existing EDL file, using it

You should delete the EDL files present with your source files if you don’t want to use them.


#5

Well that would make sense! I am having MCEBuddy monitor my recorded shows from Windows Media Center. I didn’t realize that it was generating a EDL as well. I will need to do a little digging to determine how to disable that if it is possible. Can I force MCEbuddy to overwrite an existing EDL?


(Goose) #6

No EDL’s take priority but you can write a PreMetaCustomCommand in the profile to run a batch file which can delete your EDL file.


#7

Awesome. So I think it is working…

I made a copy of the default “profile.conf” and made a new one. I placed the following command directly underneath the conversion profile I had been using, in my case the PS3/Xbox one:
PreMetaCustomCommandPath="C:\delete_edl.bat"

The bat file is pretty simple, it opens the directory where my WMC files are saved at and deletes any EDL files:
cd C:\Users\Public\Recorded TV
del *.edl

Under general settings within MCEBuddy I am now pointing to the modded profile.


#8

Hi. I wasn’t sure if I should start my own thread or not, but I am having this same issue but my original recordings are from the HDHomerun DVR and they don’t already have edl files alongside them.

Here is my setup: HDHR DVR doing the recording, MCEBuddy watching that folder and moving the file to a new folder on the same hard drive. I have two separate profiles setup. One is to using mkv normal on any mpeg2 recordings and one that is mkv unprocessed for the premium channels that are mpeg4.

I have both setup to remove commercials but only detect ads and the “add subtitles” and “add chapters” boxes checked. Under expert settings I have the miscellaneous box pointed at my comskip ini file and in the "General > Expert settings I have MCEBuddy pointed at my downloaded comskip exe file (the paid for version).

I edited the comskip ini file and in the filed for that I have changed the edl_skip_field to 3 since I view the recordings in MrMc.

However, the resulting edl file that is created contains the default 0s for the edl skip field instead of 3s. When MrMc tries to use that edl file it goes all wonky. However, if I manually change those 0s to a 3 it works perfectly fine.

So, not sure if I am missing a setting somewhere or not, but it’s not inputting the changes I have in the ini file.

Here is a log from my last test conversion:

https://pastebin.com/rwJK6rD6


(Goose) #9

I’m moving this to a bug status, MCEBuddy overwrites the values when it validates and recreates the EDL files for sanity checking. With next release it will retain the original values so this should be fixed.


#10

Awesome! Thanks!


(Goose) #11

Fixed in 2.4.9 release, it reads and retains the values for the skip action field.